Renesas


Renesas Electronics Corporation (TSE: 6723), the world's number one supplier of microcontrollers, is a premier supplier of advanced semiconductor solutions including microcontrollers, SoC solutions and a broad range of analog and power devices.

Exporting to IAR Systems

Information

In this method, you will need a license of IAR Embedded Workbench for compilation.


In this page, "IAR Embedded Workbench" will be called "EWARM".

Environment

/media/uploads/RyoheiHagimoto/iar-cmsisdap-component2.png

Install Windows serial driver

Install latest Windows Serial Port Driver to setup CMSIS-DAP from the link below:
https://mbed.org/handbook/Windows-serial-configuration

Download IAR Embedded Workbench (EWARM)

Download EWARM, and install.

Build of EWARM environment

Exporting to EWARM

  1. Goto Mbed compiler.
  2. Update your Mbed library to recent version (rev.116 or later).
    /media/uploads/RyoheiHagimoto/mbed-lib-update2.png
  3. Right click at the program you want to export.
  4. Select "Export Program"
    /media/uploads/RyoheiHagimoto/export1.png
  5. Select "Renesas GR-PEACH" for Export Target
    Select "IAR" for Export Toolchain
    Push "Export"
    /media/uploads/RyoheiHagimoto/exprt_grpeach_to_iar.png
  6. Expand zip file.

Build Process

  1. Launch EWARM.
  2. Select the [File] menu -> [Open] -> [Workspace].
  3. Select .eww file in the expanded directory.
  4. Select the [Project] menu -> [Make]

  e.g.) The folder structure when making the work folder "C:\Workspase". Export project is mbed_blinky.
    C:
    +-- Workspace
        +-- mbed_blinky
            |   .hgignore
            |   GettingStarted.htm
            |   main.cpp
            |   mbed_blinky.dep
            |   mbed_blinky.ewd
            |   mbed_blinky.ewp
            |   mbed_blinky.ewt
            |   mbed_blinky.eww
            +-- .hg
            +-- Build
            |   Exe              <- When clicking [Build Project], ".bin" and ".out" file will be created here.
            |   List
            |   Obj
            +-- mbed


The way to debug

Change debug configuration

__You need to follow this section. In future, this will not be needed.__

  1. Right-click the [Workspace] view and select [optioins]
  2. Select [CMSIS-DAP] in the [Debugger] in the [Runtime Checking] in the [Category].
  3. Select [Setup] tab and change [Reset] setting to "Software".
    /media/uploads/RyoheiHagimoto/iar_cmsis_setup_option.png
  4. Then, Click [OK]

Debug

  1. Connect USB cable
  2. Copy ".bin" file to Mbed drive
  3. Reconnect USB cable
  4. Select the [Project] menu -> [Debug without downloading].