Mistake on this page? Email us

Included software

Mbed OS

Mbed Studio ships with Mbed OS 5.12 and newer, and Mbed OS 6.

Note: If you're moving a program from Mbed OS 5 to Mbed OS 6, please note the deprecated APIs.

Mbed Studio does not support Mbed OS 2, and Mbed OS 5.11 and older.

Included software

Mbed Studio ships with the software necessary to develop with Mbed OS, including:

  • Arm Compiler 6.14
  • Git
    • Windows 2.21.0
    • Mac 2.23.1
    • Linux 2.23.1
  • Mercurial 5.3
  • GNU Debugger (GDB) 6-2017-q2-update
  • Clangd 8.0.0
  • ST-Link 2.0.1
  • Python 3.7.1 (Miniconda)
  • pip 18.1
  • pyOCD 0.27.0
  • Mbed CLI 1.10.2
  • Mbed Greentea 1.7.4
  • Mbed LS 1.7.10
Important Information for this Arm website

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies. If you are not happy with the use of these cookies, please review our Cookie Policy to learn how they can be disabled. By disabling cookies, some features of the site will not work.