5 years, 6 months ago.

Copy Paste with mbed editor

Hi, I'm having an issue with the mbed editor since I upgraded to Windows 10 - copy paste doesn't work in chrome or firefox, I just get a message box prompting me to use CTRL+V and CTRL+C. I've tried right click and the keyboards shortcuts but I get the same results with both. I am using a Surface 3 if that makes any difference? Any ideas?

Thanks

Kevin

7 Answers

3 years, 5 months ago.

In case nobody else has thought of sending feedback to Microsoft concerning this issue, I just did. Hopefully somebody there might fix this.

I do find it a bit odd and disconcerting that the MBED staff have not even commented here to give a status update. MBED MODERATORS are you listening? I do realize that this thread was started two years and a month ago, I'll give the moderators or MBED staff a couple of days to respond. If need be, I will start a new thread linking to this one to move it to the top of the stack.

Yay!!!!! The silence here is deafening....

posted by Kevin Braun 31 Oct 2017

Hello Kevin,

This is a long lasting problem , call it an MBED editor bug. No response from the editor writers. If you have solved this with microsoft please let me know. I still have the same problem.

posted by Harm Lok 10 Dec 2017
3 years, 8 months ago.

Having the same issue with Windows 10 and the Edge browser on a Asus N56 When can I expect a fix ? Makes editor pretty useless since cut and paste does work at all

4 years, 2 months ago.

It seems we still have this problem - its pretty serious in my view.

Are the mbed team going to sort it out?

4 years, 9 months ago.

Unfortunately I am having this same issue, and many others seem to be as well. I tried copy and paste on other sites, and it works on some. I looked it up, and it appears that other people have the same issues on Windows 10, and have been having these issues ever since upgrading. Maybe it is a way that mbed is encoded that doesn't agree with windows 10's implementation of copy and paste, but it appears to be a windows problem. If mbed staff know any way to fix this windows problem, I would love to hear it too.

Also using a surface?

I've not had any issues using the keyboard on a standard desktop.

posted by Andy A 04 Jul 2016
3 years, 10 months ago.

Any update?

4 years, 5 months ago.

I have the same problem on both my upgraded windows 10 computers. I think everone knows how imporant it is to copy and paste. So if anyone have a solution please let us know how to solve this problem. The Control+c and Control+v does not work at all.

Seems we still have this problem - pretty serious in my view. I am using W10

Are the mbed team going to sort it out?

posted by Andrew R 16 Feb 2017
4 years, 1 month ago.

Any updates from the mbed staff?

How many more months, years do we have to put up with this before we get an answer? Copy pasting - in W10 - is a fundamental requirement for an editor. This is ridiculous. C'mon guys!!!!!!!!

posted by Andrew R 01 Sep 2017

I have determined that that it's the "copy" that is the problem. "Paste" works fine as far as I can tell. I can copy from an offline document and paste into the online compiler just fine.

Still, you can't have one without the other....

posted by Kevin Braun 06 Sep 2017