Resolved: windows 7 serial usb driver

25 Nov 2009 . Edited: 01 Dec 2009

Just got my mbed and was trying various programs. I went to install mbedWinSerial_16466.exe and my windows 7  32bit machine stated: mbedWinSerial_16466.exe is not a valid win32 application.

I tried to setup the program as a legacy xp program however it said the same thing. Anyone have some ideas?

thanks, Michael

25 Nov 2009

Sounds like the download went bad. Try redownloading, try another browser/downloader etc.

25 Nov 2009

Igor Thanx... I tried IE8 3 times... Then went to Firefox and it worked right away. Bad windows no dinner.

25 Nov 2009

Hi John,

I had the same problem.

I downloaded the driver to my local disk, virus checked it and then went to install it. It would not install. However, it worked when I installed it directly from the web site by double clicking the object.


28 Nov 2009

How fascinating.

I'm on Win7 x64; attempting to download the file I am told that it is 594KB but IE only saves a file of 112KB. Opera has no problem saving the full-size file.

A cursory look with Wireshark doesn't show anything obviously untoward, though I've not spent any real time looking. Simon - happy to share the Wireshark log with you if you want to spend time debugging IE8...



30 Nov 2009

No probs here, I just ran it rather than saved.

30 Nov 2009

Does anyone know where to find the port (COM and LPT) settings in Windows 7. In previous versions they used to be listed under device manager. I can't find them there... 

30 Nov 2009

COM port should appear in the device manager once you connect the mbed and install the driver. If it's not there then something went wrong...

30 Nov 2009

Thank you Igor

Silly me.. I guess I was always used to it being there with nothing connected.

12 Dec 2009


I am on Win 7 x64. I downloaded the file seeral times using diferent browsers, lanched it as admin, but cannot install it. I booted the PC several times between installs without success.


In the installer window, I have the following messages :

[mbed (x64)]

1)  This application will install the mbed Serial Port driver. This may take a few minutes to complete.

2) Installing device driver... (message last half a second)

3) The dirver could not be installed

Then it is a infinite loop if I keep clicking "install".


Any idea ?

12 Dec 2009

Hi Stephane,

Can you ensure/confirm there are no explorer windows open (i.e the disk drive window) when you are installing?



12 Dec 2009

Yes, absolutely no other program running, I even closed Chrome, just in case.

31 Dec 2009 . Edited: 31 Dec 2009

Hello Simon,


I have installed the driver on my wife's laptop (win XP machine). This is great to debug programs when it works!!! On my computer I write debug traces on the 16x2 LCD and it is a real pain.

Do the mbed team has a new version of this tool coming up sometime?

I wish I could use it on my windows seven computer. I can beta test any new version if you want.