issues after updating the NUCLEO F401RE st-link v2 firmware to v2.j30.M20

05 Apr 2018

Hello all,

I am having issues after updating the NUCLEO F401RE st-link v2 firmware to v2.j30.M20, since the update everytime i connect the board to the PC (running windows 10), the USB from the nucleo wont stop refreshing after the upgrade is completed, i have tried flashing the firmware several times, to no avail, also to note the MCU is being restarted continuously in unison with the stlink, the timing between restarts varies from being consistent once a second to stopping then starting again after a few momments, it would appear the new firmware causes a potential boot-loop with this board, if anyone has any ideas on how to fix this, that would be much appreciated, failing that does anyone have a copy of firmware version 27 or 24.

Many thanks in advanced.

06 Apr 2018


I tried on several different machines (including under Windows 10) but unfortunately did not reproduced this issue so far. However, the symptoms you describe may be explained in case the system attempts to write a .bin file (for a reason to be determined) to the ST-Link mass storage interface during its initialization. It would be due to the recent change made in V2J30M20 regarding "display fail.txt if the dropped application has wrong vector values (stack pointer and reset)". Until we implement and publish an official fix for this unexpected case, you can find the previous ST-Link firmware version on github:

I hope this will help and I'm sorry for this inconvenience

19 Apr 2018

I also have issues with updating the NUCLEO F401RE st-link v2 firmware to v2.j30.M20 since the update when I am connecting the board to my HP laptop. After suggesting my friend I contacted to Customer support for this issue. Their technician also did not give the better solution.

14 May 2018


Note that V2J30M21 should now solve the issue:


13 Nov 2018

Latest version same problerm on F476 Nucleo board