Report
4 months, 3 weeks ago.

Error: The build system did not finish successfully.

I am getting 'Error: The build system did not finish successfully error 230' when trying to build a project using the on line compiler for a LPC1768 board.

Another project which had compiled successfully only yesterday no longer compiles and has the same error.

I have tried waiting for a few hours and logging out and back in again but the problem remains.

Is anyone else having the same issue?

I have tried importing blinky and get this warning: Warning: Unknown action post-build - mbed_blinky.LPC1768

posted by Andrew Boyson 27 Mar 2019

The warning was a result of compiling blinky, not of the import.

posted by Andrew Boyson 27 Mar 2019

Hi Andrew - we are root causing a problem which impacts projects based on older versions of Mbed (pre v5). What OS is your project based on (which generates the -230 error)?

posted by Ralph Fulchiero 27 Mar 2019

I am actually not using either OS2 or OS5.

posted by Andrew Boyson 27 Mar 2019

That could also be a problem as most likely your project is trying to be built with Arm Compiler 6 (which was rolled out today) but it's not compatible with Arm Compiler 6. The true build error message is being absorbed and only a -230 error is being reported. Are you using one of your public repos? If not, could you temporarily publish it so we can get another failure condition to analyze?

posted by Ralph Fulchiero 27 Mar 2019

Thank you for your help. I have just published the 'gps' program which I was working on when the compiler started failing to build. The 'heating' program was already published from yesterday when it compiled fine but today does not.

posted by Andrew Boyson 27 Mar 2019

From page 4 'Incompatible Language Extensions' of AN298 – Migrate ARM Compiler 5 to ARM Compiler 6 I can see a number of extensions 'irq', 'packed' which are no longer supported and which will doubtless cause compiler 6 to throw a wobbler.

posted by Andrew Boyson 27 Mar 2019

Hi Andrew - an update was made this morning which should fix the build problem you were experiencing. Your "heating" example now builds okay for me.

posted by Ralph Fulchiero 28 Mar 2019

Thank you, it has been building ok since this morning. I am now working to eliminate any packed or irq extensions to reduce dependencies on compiler 5.

posted by Andrew Boyson 28 Mar 2019
Comment on this question

6 Answers

2 months, 2 weeks ago.

Error: L6636E: Pre-processor step failed for '/extras/mbed-os.lib/targets/TARGET_STM/TARGET_STM32L1/TARGET_XDOT_L151CC/device/TOOLCHAIN_ARM_STD/stm32l151rc.sct'

3 months, 3 weeks ago.

Just to add and keep this alive, i'm using NUCLEO-F746ZG running basic programs and get the 'legacyalign' warning too, usually accompanied by this error:

Quote:

Error: L6636E: Pre-processor step failed for '/extras/mbed-os.lib/targets/TARGET_STM/TARGET_STM32F7/TARGET_STM32F746xG/device/TOOLCHAIN_ARM_STD/stm32f746xg.sct'//

3 months, 3 weeks ago.

I've had all the above problems and more also many peripheral devices become problematic or unusable in particular the 1-wire and some Ethernet and Wi-Fi libraries.

After spending several days testing, as of 24/4/2019, I am using the following libraries;

The STM32F767, F746G and possibly most other STM targets, LPC1768 plus other basic line targets, the following libraries seem to be working well:

Mbed-os rev.510 dated 17th November 2018

Mbed (os2) rev.171 dated 8th November 2018

Mbed-Dev rev.187 but can't access the revisions tab, it times out and it's now extremely difficult to import.

I recommend to try the latest Mbed libraries first and switch back if you encounter problems.

4 months, 3 weeks ago.

Same problem for the Microbit board.

Hi Borja - we've discovered that projects which utilize the microbit-dal (Device Abstraction Layer) presently won't build with the Online Compiler. Our development team is currently looking into this. Apologies for the inconvenience.

posted by Ralph Fulchiero 27 Mar 2019

Indeed, solved some days back. Thanks!

posted by Borja Eurecat 09 Apr 2019
4 months, 3 weeks ago.

Also experiencing spotty compile problems for the same code. I usually receive this Warning when the online compiler fails.

Warning: L3912W: Option 'legacyalign' is deprecated.

Thank you for the report. It's not clear what is causing the inconsistent performance but we are aware of it.

posted by Ralph Fulchiero 27 Mar 2019
4 months, 3 weeks ago.

Same problem here, Build that compiled and ran fine yesterday, now doesn't.

Version. 5.09. 5.10, 5.11, 5.12. makes no difference.

On a brand new fresh blinky I get Warning: L3912W: Option 'legacyalign' is deprecated.


You need to log in to post a question