Report
1 month, 3 weeks ago.

How to import an mbed program from Mbed Online Compiler?

Hello, I'm trying to import a program from Mbed Online Compiler. As written in the guide I downloaded it as zip file and I pasted it in the Workspace folder. Then in Mbed Studio Beta I tried to make it as Active Program but the result is the following message: " Cannot set 'ProgramPath' as Active Program. Not an Mbed Program ".

I think that the idea of a Desktop IDE is very useful and nice idea. Can someone help me please?

Best regards Davide

Question relating to:

Comment on this question

2 Answers

1 month, 3 weeks ago.

Hi Davide, when a zip file gets exported, there are two layers of folders. If you move only the lowest level one into your workspace (e.g. the folder that directly contains the source), then that should work.

Let me know if that helps?

Thanks, Joe

Hi Joe, thanks for your reply. I tried to do what you told but the program does not work anyway.

Thanks, Davide

posted by Davide Larcher 04 Mar 2019
1 month, 3 weeks ago.

Hi Davide, you probably tried to use program with mbed 2 library. I had same issue ("Cannot set 'Program Path' as Active Program. Not an Mbed Program") when I tried that. The program must be with MbedOS 5.

So the new tool cannot be used without an RTOS (bare metal) or with ver. 2 RTOS at all? Are there any plans to support that?

posted by jim hamblen 01 Mar 2019

Here is the answer for your question https://os.mbed.com/questions/84891/Mbed-Studio-and-Mbed-OS-2/

posted by Jan Kamidra 01 Mar 2019

Hi Jan, thanks for your answer. I think the one that you told me should be the problem. But on the Mbed Online Compiler how I can choose to use MbedOS 5? I simply created a new program without choosing the MbedOS. Is there a way to convert my program to MbedOS 5?

Thanks again Best Regards

posted by Davide Larcher 04 Mar 2019

Hi again, you can simple replace the library in the project folder in the online compiler. Delete your current mbed library from your project folder and the best way is to use - right click on the project folder and select "import library... >> from URL..." and use https://github.com/ARMmbed/mbed-os.

Best regards J.

posted by Jan Kamidra 04 Mar 2019

To post an answer, please log in.