Report
1 week, 4 days ago.

LPC1768 tripping when connecting to common ground

I'm trying to run a NEMA 17 stepper motor using a L298N with a LPC1768 dev board. Earlier whilst using a bench power supply everything worked smoothly, however now that I'm trying to use a plug-in 12v supply I'm running into issues. As soon as I connect the common ground (-ve from the barrel jack, GND on the L298N, and GND on the LPC1768) the system resets. I assume this is due to some over-current or over-voltage issues. However this exact setup worked earlier. Any suggestions?

Comment on this question

1 Answer

1 week, 4 days ago.

When you say Resets, does it cycle or reset and then work. Also check the 12v power supply current rating and make sure it can handle the initial current inrush when connecting. Do you have a separate regulator for the LPC1768, Vin is max 9v, I would suggest 5v regulator. Also add decoupling capacitors on the the L298N and LPC1768 regulator outputs.

Reset then works again after removing the ground. I'll test how much current is drawn tomorrow. Maybe the L298N is broken... The LPC1768 is powered via USB for now but the L298N has a on-board regulator for outputting 5V

posted by Jan-Hendrik Ewers 12 Feb 2019

Where is the USB power coming from? Is there the possibility that the USB GND and the 12V GND are at different voltages for any reason? Normally DC supplies are either floating or GND is connected to the earth voltage from the power input but there is always the possibility of something odd

Do you have a USB battery pack handy? If so power the mbed from that so that its GND is floating and see if the problem goes away.

posted by Andy A 12 Feb 2019

To post an answer, please log in.