2 years, 5 months ago.

need to plug out the usb of LCP1768 and back in before the program works

hello

I just bought the lcp1768 and tried to run the mbed_blinky program from the library. My lcp1768 didn't do anything, so I tried the reset button, updating the firmware, instaling the serial ports but still nothing. Then I tried to plug out the USB cable of the lcp1768 and back in and afterwards the led1 started to blink as it should.

So every time I change a program or make a new program and put it in my lcp1768 I need to repeat this process of pulling it out and back in before the lcp1768 does the new code (otherwise it keeps continuing the code of the previous program that was in there).

To me, this doesn't seem like how it should work. What do I wrong or is there a software fault somewhere?

With kind regards

Agree with Wim, but I'll offer something else to ponder. What version of software is on the LPC11U24? I have seen that some versions behave a bit different than others - some don't "refresh" into Windows explorer immediately (and the power-cycle is required).

posted by David Smart 20 Feb 2019

1 Answer

2 years, 5 months ago.

After downloading the new code or drag&drop of the code to the mbed ''memory stick'', you do need to press the reset button on the LPC1768. That should restart the device with the new code. Some mbeds that I used have developed issues with the resetbutton (internal corrosion maybe). Make sure to use enough force when pressing the button. A powercycle will obviously perform a hard reset as well.

Note that the mbed memory stick that shows on the PC has limited space. You will have to delete some of the old bin files every now and then. Also note that only the most recent bin file will ever be flashed into the target so make sure the date on your PC is set correctly.

Accepted Answer