2 years, 10 months ago.

When will this board be supported by the MBED OS 2 Libraries?

For these small boards, I tend to use the MBED 2 libraries as opposed to the full RTOS. I was expecting projects which already compile for the LPC1768 module to work with this as they have the same module pin assignments. Can someone from L-tek provide a timeline for full MBED2 compatibility with this module?

Thanks!

Question relating to:

The L-Tek FF-LPC546XX is a small, 40-pin development board intended for prototyping general microcontroller applications. It is based on a low power, peripheral rich and debug capable NXP LPC54606 microcontroller, …

Hi, we have raised this question to mbed dev team. You can can see it here: https://github.com/ARMmbed/mbed-os/issues/5887#issuecomment-399417927

We hope it will be resolved soon.

posted by Gorazd Kovacic 22 Jun 2018

Hi Gorazd, Looks like this has stalled on the linked thread. Any update on MBED OS2 support for the L-Tek LPC546XX module? Thanks!

posted by Douglas S 23 Jul 2018

It sounds like new software is coming that supports ver 5.0 but without the RTOS, so perhaps at some point in the future that will work on this board. I would also like an upgrade to the LPC1768 in the same package - could use the extra RAM and faster processor. We still use breadboards and most other boards do not just plug in directly.

posted by jim hamblen 12 Mar 2019

I just tried the new OS 5 bare metal blink LED example at https://os.mbed.com/docs/mbed-os/v5.13/reference/mbed-os-bare-metal.html and it works now on this board using the cloud compiler. Build option did not display the code size in compiler, but it looks like no OS used.

posted by jim hamblen 04 Sep 2019

1 Answer

2 years, 10 months ago.

Hi Douglas,

I would recommend reaching out to L-Tek directly with this question, their email as provided on the L-Tek FF-LPC546XX board page is info@ltek.si

Please let me know if you have any questions!

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

Hi Jenny, Looks like the build system has an issue with duplicate targets for this platform. A known issue based on the github link above. At least a couple of builds have happened since then and I'm still not seeing any progress on this. The gist I'm getting from the thread is that it's a fairly simple edit to the targets.json to fix this? Any help would be appreciated :D

posted by Douglas S 04 Oct 2018