Report
1 year, 2 months ago.

NUCLEO-L432KC binary from online compiler not working with other STM32L432KC board

Hello,

We have developed an STM32L432KC board. we can blink an LED creating a program from CUBEMX , compiling with Atollic, flashing with J-Link.

The mbed blink flashed with J-Link or DfuSe Demo is not working. If we export the mbed program to KEIL, then after compilation and download with KEIL/J-Link it works.

Additionally having the CUBEMX blinking program working, if we re-flash with the mbed binary, then the existing program is not erased and keeps working.

We have noticed that the IC on the NUCLEO-L432KC board is STM32L432C, not KC, but we can't find any info on such part number! Is STM32L432C a special engineering sample with different memory map and a special implementation from mbed compiler, not compatible with production STM32L432KC, or something else?

Regards Nikos Chalikias

Question relating to:

Affordable and flexible platform to ease prototyping using a STM32L432KCU6 microcontroller.
Comment on this question

2 Answers

7 months ago.

happening the same issue, I noticed that other users are facing the same problem,

basically any program I compile and download on mbed doesn't run on the micro.

tried on 6 different brand new units, please give us some support in solving it.

thanks

UPDATE updating the ST Link fw solved the issue, everything fine now, thanks!!

Hi Did you check your FW version ? https://os.mbed.com/platforms/ST-Nucleo-L432KC/#known-limitations regards,

posted by Jerome Coutant 18 Jan 2019
1 year, 2 months ago.

Did you try drag and drop?
the file generated by mbed is a binary file. you just need to save it on the virtual drive that appears when plugging the nucleo board to your PC.

Regarding the marking information, they are described in the device datasheet (p151 in current version):
STM32L432KCU6, this is in line with what you read on your device.

Hello Maxime,

Thank you for answering, but ,

- The issue is not with Nucleo board but with our own development board and we have no drag and drop. As mentioned above we can program the board, if we export the mbed project to Keil and program with J-LINK. But the on-line compiler binary is not working. We don't need drag-drop for this, J-LINK can flash a bin file. ( ...We can do this for our own design boards with LPC1768, LPC11U35, STM32L152, nRF51, nRF52 but not for L43KC)

- p151 of the datasheet says [L432KC], the chip on Nucleo says [ L432C] and this is NOT IN LINE with datasheet! THERE IS NO "K" before "C" on the chip

So the question is: Is mbed on-line compiler bin for NUCLEO-L432KC working only for the Nucleo board and not with any other STM32L432KC board? And if yes, is this due to a special engineering-sample or undocumented CPU used for the Nucleo?

Regards, Nikos

posted by nikos chalikias 17 Jun 2018

Ok, I got some additional information.

The device on the NUCLEO-L432KC is a STM32L432KCU6U so the marking is a bit different to be able to distinguish. STM32L432KCU6U is fully compatible with the STM32L432KCU6. The only difference is that it unlocks any royalty based software stack that could eventually be offered for this device. (but I don't think there are any available at the moment) . This approach already exists for other STM32 series with third party JAVA and graphical stacks for example. The STM32L432KCU6U only exists on MCU evaluation boards and is not available for sale.

I suspect your problem comes from something else. I recommend you check for differences between your board and the NUCLEO-L432KC . Maybe the oscillator circuit?

Best regards, Maxime

posted by Maxime TEISSIER 18 Jun 2018

You need to log in to post a question