7 years ago.

I can't upgrade to mbed

This seems silly - I can install the PE Micro Applications but when I install the mbed software the mass storage device never comes up.

When I put the board back into bootloader mode sda info shows: "Application Version is: 0.00"

I thought maybe the s19 file was corrupt, but I've downloaded it twice.

I've also upgraded the bootloader to see if that makes a difference but to no avail.

Am I doing something stupid?

Question relating to:

I had the same problem because I didn't extract the files from the .zip folder.

posted by Liz Anderson 26 Jun 2013

8 Answers

7 years ago.

Did you get this to work eventually? Can you describe the exact steps you are taking to load the s19?

Tom L
poster
7 years ago.

Still not working, I just drag and drop the s19 or do copy src dest from the cmdline. Then I unplug and replug the device - the green led lights but the usb mass storage never appears.

I have bootloader 1.08 if that makes a difference.

Thanks for your help, Tom

Ok it worked straight away that time! Not exactly sure what I did differently. I think I had the wrong MSD loaded, as I installed msd-frdm-kl25z_pemicro_v107.sda then mbed and it worked straight away.

posted by Tom L 02 Apr 2013

I have exactly the same problem with you, can you explain in detail how to solve it?

posted by isro hutama 20 May 2013
6 years, 9 months ago.

I am also having this issue with my new board.

I use Windows 7 x64.

I can access the bootloader partition no problem, and copy the file across. I have used both drag and drop, and command line copy.

After I unplug the board then plug in again, there is no mass storage device. I check in the device manager, and cannot see it anywhere.

I also plugged into a spare Win7 32 bit PC, same issue.

Accessing the SDA info from the bootloader partition shows the application version as 0.00

If I copy the PE Micro MSD file to the bootloader, after restarting the board, the mass storage device pops up correctly (although as a KL25Z board, not mBed).

This is exactly the same problem I had. Have you tried using 1.07 (msd-frdm-kl25z_pemicro_v107.sda)? That solved my problem, I was mucking about with other stuff before I tried mBed.

posted by Tom L 25 Jun 2013

I can only find v1.09

Mine is a brand new board, not been used for anything else yet

posted by Dave Kelly 25 Jun 2013
6 years, 11 months ago.

The KL25Z board will show a mass storage area on boot but this is not where you copy the files too. Instructions should read:

HOLD DOWN RESET WHILE PLUGGING IN USB

You will then get a BOOTLOADER area to copy the mbed s19 file to.

UNPLUG, THEN REPLUG IN USB

On windows it will now install the USB driver and then display the mbed drive.

6 years, 10 months ago.

Hi All,

There is a known issue with the upgrading if you are using a Linux or Mac computer. We are working with Freescale and PE Micro to overcome this.

As long as you are using a Windows machine, the upgrade process will run smoothly, as per the instruction in :

https://mbed.org/handbook/mbed-FRDM-KL25Z-Getting-Started.

Can you confirm if the issues you are seeing are while using a Windows machine or Mac/Linux?

Thanks, Chris

it is in windows 7

posted by isro hutama 20 May 2013

Ubuntu 12.10 host, 64 bit.

I'm in this situation where the KL25Z won't take the mbed firmware. I'm following the power-up while pressing reset, copying the file, unplug/plug. The board rejects the file. Copying the 1.07 or later .SDA from PEMicro did not help - after copying them in, the board no longer runs the factory LED/accelerometer applications.

Just taking a guess here - is this some sort of incompatibility between how Ubuntu vfat filesystem and PEMicro's interpretation of how a fat filesystem is formatted? I have not tried Windows yet - nearest Windows machine is 100+ miles from where I'm playing with the KL25Z..

KL25Z info: Microboot 1.05, Bootloader 1.09, Application Version 0.00.

posted by Rick Spanbauer 20 Jul 2013
6 years, 10 months ago.

I don't know the cause of this problem, but i can solve this problem like in https://mbed.org/questions/1084/mbed-FRDM-KL25Z-cannot-be-detected-in-wi/

6 years, 8 months ago.

Hey all- I've been having this bug as well, and i think I've just solved it. I suspect this is a bug in the mbed firmware because I can either load the mbed firmware or not depending on the application (not firmware) I had installed BEFORE I tried to load the mbed firmware. I solved this by: 1. Download the FRDM-KL25Z_QSP quick start package from freescale: http://cache.freescale.com/files/32bit/software/board_support_packages/FRDM-KL25Z_QSP.zip?fpsp=1 2. Download the firmware apps from pemicro: http://www.pemicro.com/opensda/index.cfm 3. (optional) Update the bootloader by loading BOOTUPDATEAPP from the pemicro firmware apps onto the FRDM 4. Load the FRDM MSD firmware v112 from the pemicro firmware apps onto the FRDM 5. Load the pwm_led app from the freescale quick start precompiled examples 6. Load the mbed firmware

If this doesn't solve it for you, try loading a couple of the other precompiled examples from the freescale quick start package before loading the mbed firmware. I can reliably prevent my FRDM from loading the mbed firmware and re-enable loading the mbed firmware based on what app I load before trying to load the mbed firmware.

Let me know if this solved your problem! James

6 years, 5 months ago.

Hello,

Has this been resolved? I'm having issues with this on both OS X and Windos 7. Bootloader comes up fine on both platforms; however, after copying the firmware to Bootloader, MBED doesn't come up.

Please Please assist!

Thanks.

I just got 2 Freescale FRDM 25's and have tried W7, W8.1 and Mac OS X. All behave EXACTLY the same,

They allow me to copy the s19 file onto the BOOTLOADER, but when unplugged/plugged no mbed drive.

Also, I checked I am using bootloader v 1.09

posted by Berean Brain 14 Dec 2013