4 years, 11 months ago.

Latest mbed v123, rtos v119, EthernetInterface v54 SDFileSystem v23 and K64F give compiler errors

I think that SDFileSystem needs updating: Compiler errors (2):

Error: Member "mbed::FileBase::_name" (declared at <a href="#" onmousedown="mbed_doc_goto('/K64F_VEML60xx-122extras/mbed_b0220dba8be7/FileBase.h', '73'); return false;">/extras/mbed_b0220dba8be7/FileBase.h:73</a>) is inaccessible in "SDFileSystem/FATFileSystem/FATFileSystem.cpp", Line: 52, Col: 69

Error: Member "mbed::FileBase::_name" (declared at <a href="#" onmousedown="mbed_doc_goto('/K64F_VEML60xx-122extras/mbed_b0220dba8be7/FileBase.h', '73'); return false;">/extras/mbed_b0220dba8be7/FileBase.h:73</a>) is inaccessible in "SDFileSystem/FATFileSystem/FATFileSystem.cpp", Line: 70, Col: 73

Regards,

...kevin

Question relating to:

The Freedom-K64F is an ultra-low-cost development platform for Kinetis K64, K63, and K24 MCUs.

Thanks for reporting Kevin - Will get this updated.

posted by Sam Grove 18 Aug 2016

Hello all, I am getting the same errors. Can some one guide me on how to fix those above error? please help Thank you

posted by navya rathi 19 Aug 2016

Neil Theissen, who is kind enough to keep SDFileSystem current says that FATFileSyetem is old and needs updating back at GitHub. I have no idea how that works....

posted by Kevin Braun 19 Aug 2016

2 Answers

4 years, 11 months ago.

Thank you guys for reporting. I pushed an update to FAT library (to include getName bugfix), now it should compile.

Accepted Answer
4 years, 11 months ago.

Had the same issue, although on another platform than you're using. Initially I thought it was a problem in the SDFileSystem lib. Eventually for me the compiler error went away by reverting the mbed library (that I had just updated) back to an older version (25th may 2016 - R121) while still using the latest SDFileSystem lib (26th may 2016). Probably not the best long-term approach but at least for now I got things compiling again at my side.

And that's how I am able to continue, by using older versions of mbed, mbed-rtos and EthernetInterface libraries. Still doesn't address the issue however....

posted by Kevin Braun 22 Aug 2016