3 years, 4 months ago.

USB Virtual serial port with Tera Term

Hello. I have used Tera term with my mbed1768 for a few years without problems. However, yesterday, after it worked twice to program a device using ISP and Tedd Okano'sa ika shouyu poppayaki [sp?] it suddenly stopped working. I've checked the cable, swapped the 1768 module out (I have 3 of them) and I get nothing on teraterm. When I plug the USB into the mbed, the system recognizes it and a window with the mbed contents opens up. I hit reset on the mbed, expecting the ISP program to come up in tera term - nothing. I've checked the com ports - the USB comes up as come port 3. Any help will be greatly appreciated

Additional info - when I select new connection, I can see the mbed device in there on Com 3 and I can select it. I have selected serial and not TCIP in the dialog box as well.

posted by Andrew R 12 Jun 2016

I've just run the serial port test which prints 'Hello World' on Tera Term and that is working correctly. Still no luck with Tedd Okano's ISP program though. I'll keep digging.

posted by Andrew R 12 Jun 2016

ok - its working again. I cleared out my download filwe - I had about 10 copies of the ISP program in there and my application program. With only a single copy in the windows download file that I then drag into the attached mbed device it works ok. I noted that you can have a few copies in the down load folder before windows automatically assigns a copy number 'n' as in filename(n).bin . This is what was causing the issue.

posted by Andrew R 12 Jun 2016

Thank you for using my ISP writing program! Good to hear that the problem had been solved :) mbed takes latest *.bin file as its application program if there are multiple *.bin files. It may help to find timestamp of the *.bin files to find which will run on the mbed.

posted by Tedd OKANO 13 Jun 2016

Thank you for clarifying Okano-san :)

posted by Andrew R 13 Jun 2016
Comment on this question

1 Answer

3 months, 2 weeks ago.

hi how did you clear the download file plz