4 years, 4 months ago.

How to add this platform to MBED compiler ?

There is no option to add this platform to the mbed compiler , at least I personal can't find any. Could someone guide me how to add the platform and run some basic demo example on it by using mbed of course.

Thanks in advance.

Question relating to:

The STM32F746G-DISCO discovery board (32F746GDISCOVERY) is a complete demonstration and development platform for STMicroelectronics ARM® Cortex®-M7 core-based STM32F746NGH6 microcontroller.

Who developed the code of the demo preloaded on the card? Where you can download the source? Thanks

posted by Carlo De Bonis 16 Jul 2015

Hi Carlo, the code is available from the ST Website:

http://www.st.com/web/en/catalog/tools/PF261909#

Look in the "Demonstration" folder in the Cube firmware archive that can be downloaded from the above link. Right now it compiles with Keil, IAR, and System Workbench for STM32 (open source). I haven't been able to properly link the code (but it does compile) with System Workbench, but the full-featured version of IAR works well.

posted by Mehmood Nurmohamed 17 Jul 2015

Sorry, Mehmood, I'm still totally lost! Your comment points to a source for Cube firmware. That link leads to a page with a number of pdf's, and one link to "STM32CubeMX". Clicking that expands to a number of apparent libraries/sources. One is "STM32CubeF7" and the description looks like the demo firmware. Clicking through *that* simply closes the expanded list. Nothing leads to an actual code library, nor loads it into the Compiler.

Dave

posted by David Bell 21 Jul 2015

Hi Dave,

The source code is in the link to the STM32CubeF7 "download" button on the bottom right of the page referenced in the link above. I am using Chrome as my browser. Navigate to the bottom of the page to the section called "Sample & Buy". When I click the red "Download" button there is a file called "stm32cubef7.zip" file that gets downloaded. Let me know if that works. It's quite subtle and easy to overlook the download link.

posted by Mehmood Nurmohamed 22 Jul 2015

I haven't tried it in Chrome. I'm using a recent version of Firefox; maybe that's the problem. I'll report back!

posted by David Bell 22 Jul 2015

That's it! zip file is downloading properly. Possible corporate firewall or configuration in Firefox... OK, the zip file contains SetupSTM32CubeMX-4.9.0.exe I'm slightly surprised that policies in effect on my PC allowed me to execute it. It appears to be installing the complete set of example programs for all STM32F7 targets. (8558 files, 733+MB) Can we use these projects and files with the online Compiler, or do we need to install a toolchain locally?

Thanks for all the help!

Dave

posted by David Bell 22 Jul 2015

Hi Dave, it appears that the STMicroelectronics folks are still porting their HAL to mbed. As a result the only way to build the demonstration application is to install an offline IDE such as IAR (the full-version trial not Kickstart edition) or Keil. I can't get the System Workbench IDE to link the demo code so your best bet for an "out of the box" experience would be to try IAR Embedded Workbench or Keil.

posted by Mehmood Nurmohamed 22 Jul 2015

Well, I'm in no great hurry to develop anything with the Discovery Kit, so I can wait until it gets ported to mbed, I suppose. I'm not really in a position to install an extensive toolchain just now. On a related question, though, does the large library (8558 files) left open in the zip file get installed during the setup process? Where? I can't find them under C:\Program Files\STMicroelectronics or elsewhere. Should I extract them and drop them under C:\Program Files\STMicroelectronics somewhere?

Thanks again!

posted by David Bell 22 Jul 2015

Yes, I would recommend extracting the zip file to a known location. Since you are using using Windows just make sure to install it to a location where you don't have access restrictions. Sometimes, installing in C:\Program Files can be problematic. If in the future you want to experiment with the System Workbench IDE (GCC/Eclipse based) I would recommend extracting the zip file to a directory that doesn't have a long path or spaces. There are some compiler/debug issues with that IDE when path names are too long.

posted by Mehmood Nurmohamed 22 Jul 2015
Comment on this question

9 Answers

4 years, 3 months ago.

I'm disappointed. not with the hardware but I thought I could just get the board and start playing with it and Mbed. I have d one now and I can't add the board to the mbed compiler. The cardboard insert doesn't even have the word Mbed on it but does list several other compilers.

Connect the board through the USB. You will see the mbed drive. Open the HTML file using the browser you will find the link to add the board to the compiler.... I have not done beyond that....

posted by Baskaran Kasimani 05 Aug 2015
4 years, 4 months ago.

i have ordered for this board. This board is on the way. Would like to know when this will be fixed....

Got the board. The pre-programmed demo runs on the board. I can add the board to the mbed - but no documentation on how to run the LCD etc....

posted by Baskaran Kasimani 13 Jul 2015

How do you add the board to mbed?

posted by Asbjorn Mikkelsen 04 Aug 2015
4 years, 4 months ago.

This board was added to the list of mbed platforms in the last week or so. The vendor is still busy finishing the mbed library implementation. At that time the compiler option should be added also. Note that several other boards (gecko, wiznet) are in the same phase of completion. You may want to try switching to the mbed beta site. The compiler option will probably be available first in that mode.

4 years, 4 months ago.

From where this board or any other mbed M7 based dev kit available to buy immediately?

4 years, 4 months ago.

I received the board yesterday from farnell but have not been able to complete a compile, keep getting error 230. I presume the tools are incomplete at this time. I verified the system and the code works with a Freescale K64 board so it has to point to the backend of mbed for STM32F7 I guess.

Is there tools at all online here?, I turned on the beta thingy (I think I did it correctly), but still no option to add the board.

posted by Asbjorn Mikkelsen 09 Jul 2015

I received my board a few days ago and am anxious to work with it...but I guess we have to wait until ST finishes the MBED porting effort..........................................................................David G.

posted by David Garrsion 10 Jul 2015

I am investigating the stand alone option of eclipse ad the built in STLINKV2-1 SWD device. I will post my findings if I make a breakthrough. It's not mbed but it may provide some insights, or something to work on in the short term.

posted by John McGloughlin 10 Jul 2015
4 years, 4 months ago.

Is this platform now supported, or still mbed is lying ?

How are they lying? Doesn't it have still status pre-order?

Anyway I added it to my compiler with a workaround, but it won't actual compile yet. So no it does not work yet.

posted by Erik Olieman 18 Jul 2015

Folks need to understand that it's the vendor's responsibility to meet the mbed specification. That is why mbed provides open-sourced HDK & SDK. Mbed doesn't provide for all the features of each vendor's chip, that is where we as users can contribute our talents to make the product more complete. Mbed is just the basic and we(& mbed) add the extras. [I am still waiting for MicroMint to complete the Bambino210E process]

posted by Gary Z 18 Jul 2015

@Gary, to be fair I also don't understand the mbed side of things. Also it is easy to tell the community to do it, when ARM is definately earning the money.

However more to the point: There are mbed targets which work completely and where they just need to press the 'release' button, which they don't do. And there are mbed targets added like this one where you simply cannot add it yet to the compiler. Finally there are also enough mbed targets added which are horribly broken at the start.

It is extremely clear that they got major double standards.

posted by Erik Olieman 18 Jul 2015

@Gary Isn't it clear that platforms on the website are "mbed-enabled" ? From the wiki "The full list of mbed-enabled platforms with associated pinouts and firmware updates can be found on the Platforms database." you can read further that software can be compiled for those targets. However this is not the case, apparently not all hardware there, is "mbed-enabled". It's seems not right to endorse something as working with mbed framework, if it does not. It's advertising something that is not true, at least for the moment. Like @Erik wrote, it's easy to say, guys implement it yourself, but that somehow kills the point of having such a platform right ? Not to mention that so called official libraries which you call basic, are in many ways broken and it seems like they expect users to fix that as well.

posted by Mateusz Kaduk 18 Jul 2015

It's not an ARM issue, they only licence their core processor designs for other manufactures to use. These manufactures (vendors) have the responsibility to support their devices and certainly not unpaid users on Mbed.

Mbed has a responsibility NOT to add any platform unless ALL the peripheral libraries for a device are fully working and tested and these platforms should not be visible in any way until that has happened.

From a business angle it is not advisable to alienate customers (users) from using their products. By not supporting their products as we have seen on Mbed, this effect can be catastrophic. It takes a long to build confidence between a customer (user) but a very short time to destroy it.

Unfortunately ST has not yet provided a complete reliable working library source on Mbed for any of their devices. To that end it is highly unlikely that this device will be any different.

By doing this the commercial result could potentially be very damaging.

If you had a 100k+ unit design business plan, which vendor would you use?

I find it very odd that most vendors will produce library products available on their own websites but do not employ these on Mbed. The fact that they do exist indicates they have capable staff to make this happen, so where are they and really how long would it take talented guys to do this?

Connecting external peripheral devices is where Mbed and the community should come into play. Sharing ideas, experiences and knowledge helps to improve the quality of programming where everyone benefits from beginners to experts.

posted by Paul Staron 18 Jul 2015
4 years, 4 months ago.

I agree with most people here. Platforms that has no working libraries or cannot be added to the compiler, or even are unavailable, should not be listed on the Platforms page. That will actually drive manufacturer to have their platforms ready to use, rather than do cheap advertising on this site. People are wasting their money and time and finally they have to put it in a corner for months, or have to dispose the v0.7 platform after all, because it is surpassed by other well-supported platforms. Maybe is is a good idea to utilize a check-list which has to indicate a 'Pass' as an outcome before products can be even listed here.

Unit testing of embedded firmware for the compliance with mbed libraries along with reports on website indicating which features are guaranteed to "Pass", could be one attempt of rebuilding shaky users trust. Although, full compliance would be preferable. Otherwise producer should not cheat users advertising products as "mbed-enabled". Now it seems people pay for empty promises which may or may not eventually happen before device gets old or obsolete. I would order this board, but I chose not to commit the same mistake twice.

posted by Mateusz Kaduk 18 Jul 2015

That's a good idea Mateusz, I fully agree with you. A page section 'Library Features' could be added, which indicate 'Pass' per item and a average percentage "mbed-enabled". It can be displayed on the same page that lists the Features, which may be renamed 'Hardware Features'. Platforms that do not have both the buttons "Add to your mbed Compiler" and "Buy Now" should best be removed. For example the Renesas GR-PEACH (a shame on itself, which is listed for ages without availability), and this DISCO-F746NG.

posted by Jack Berkhout 18 Jul 2015

Thats also why I started working on table with targets and their capabilities from the source code (well and mainly because I thought it was a nice challenge). (https://developer.mbed.org/forum/news-announcements/topic/16604/). Because if you extract such things from the source code directly a manufacturer cannot 'cheat'. You cannot say your MCU has CAN, when it indeed has CAN but it is not supported by the mbed CAN library.

posted by Erik Olieman 18 Jul 2015
4 years, 4 months ago.

I agree with many of the comments mentioned here. I bought a Nucleo boards F103/F401 when they first came out, only to keep them on the shelf for almost year before mbed support for them was usable. USB (mbed USBDevice) support for the 411RE was completed as recently about 1-2 months ago and USB device support for the F103/L152/L0/F0 boards is still not there.Having a list of what works and what doesn't for each board would help.

I do think that perhaps two versions of the mbed libraries need to maintained; a stable and staging version. A part/board is first added into the staging library and stays there until complete bug-free support is available. It is finally added to the stable library only after it has been tested thoroughly in the staging phase. The board should not be advertised on the mbed site whatsoever until the board makes it into the stable library.

4 years, 4 months ago.

Hi All,. I was able to run mbed_blinky in STM32F746G_DISCO today. Then I summarized how I did it.

https://developer.mbed.org/users/mzta/notebook/building-mbed_blinky-for-disco_f746ng-at-local/

We cannot use online compiler yet, but we are able to get a source code of STM32F746 in mbed-src, so I tried to build at local compiler.

I hope that it will be help to you. thk.

Graphics are incomplete because the graphics are located in the QSPI-Flash. But to program the QSPI-Flash I think we need ST-Link V3.7. But I can only find ST-Link V3.6 at ST-Website :(

Forget it, ST-Link V3.7.0 is online : http://www.st.com/web/en/catalog/tools/PF258168

posted by Lutz Schulze 24 Jul 2015

Thank you for telling me about. V3.7 is online now. That is to say, is it able to write to the QSPI-Flash? I found a description of " Added support of N25Q128A external flash memory programming on STM32F746G-DISCO" in V.3.7 Release note. That's good!

posted by sabme ua 24 Jul 2015

I was able to write DemoApp using ver.3.7.0. It is working completely. Thank you, Lutz.

posted by sabme ua 24 Jul 2015

Hello takuya matsuzaki,

may I ask you a question ? Can you play a audio or video file with your demo software ? Its not working for me and I believe I am doing some silly fundamental wrong...

Thank you for your help.

posted by Lutz Schulze 05 Aug 2015

Hello Lutz,

There are some problems below, but I can play both audio and video.

  • It can play only via USB memory connected to OTG.
  • It is successful in only by the prebuilt hex file that is included in STM32F7Cube. The binary that I compiled by GCC cannot show the file list.
  • It froze up during audio playback several times.
posted by sabme ua 05 Aug 2015

You need to log in to post a question