HTTP server

04 Dec 2013

Hi I want to create a simple web server application. Which project is the best I have tried the RPC over HTTP server but I don't need RPC, is there something better for my needs?

Also I just got two brand new LPC4088 modules. But when I compile the RPC over HTTP server code I get the following error: Error: Cannot open source input file "cmsis.h": No such file or directory in "EthernetInterface/lwip-sys/arch/cc.h", Line: 103, Col: 18. It compiles fine and works when targeted to the LPC1768 platform? Any ideas what I'm doing wrong. Thanks

06 Dec 2013

I have a working HTTP server that can serve files from an SD card and process URL encoded I2C, GPIO and PWM commands. It is working on the LPC1768, but I do not have an LPC4088 to test it with. You will need to remap the pins to get it to compile for the LPC4088.

06 Dec 2013

Hi Ian,

Networking should work with the LPC4088. Your problem might be related to an old version of the EthernetInterface and or mbed library. If you click on a library (when in the mbed compiler) you will see Library Details to the right. In the Summary you will see if there is a newer library available. Just click update and you will get the latest.

I have in the past tested the (server like) application below with the LPC4088

Import programHTTPServer_echoback

Simple HTTP server example with EthernetInterface lib. access the mbed via any browser, mbed echo back http request header.

To complicate matters it seems as though the latest update of the mbed library has messed up things for the LPc4088 target since networking doesn't work anymore. it will be possible to compile, but no IP address is assigned when running. I have to investigate who had made changes to this target and what has actually been done. There is a workaround though.

  1. Update each library (EthernetInterface, mbed+rtos, mbed) to the latest version.
  2. Click on the mbed library and then the Revisions button in the Library Details view.
  3. Click on revision 70 in the list and then the Switch button.
  4. Compile and download
  5. You will see the IP address in the console. Just use a browser and access this IP address (this worked for me)

Andreas @ Embedded Artists

19 Dec 2013

Hi Andreas,

I powered up a LPC4088 for the first time. I am having compiler errors:

Error: A1854E: Unknown opcode 'VSTMDBEQ', maybe wrong target CPU? in "mbed-rtos/rtx/TARGET_M4/TOOLCHAIN_ARM/HAL_CM4.c", Line: 157, Col: 1

Error: A1854E: Unknown opcode 'VLDMIANE', maybe wrong target CPU? in "mbed-rtos/rtx/TARGET_M4/TOOLCHAIN_ARM/HAL_CM4.c", Line: 175, Col: 1

There are 4 errors total, two of each error above. I have the LPC4088 target selected and using v70 of mbed.


20 Dec 2013

Hi Kevin,

I have reported this to the mbed team. The errors most likely have to do with FP (floating point) option not being set when building the mbed-rtos library. It is set correctly in the mbed SDK so it seem to be something that isn't working in the mbed compiler (a script that has changed maybe).

All was working when I wrote my previous reply 13 days ago. When I get feedback from the mbed team I will let you know.

Andreas @ Embedded Artists

07 Jan 2014

Hi Kevin,

The mbed team has now fixed the problem in the online compiler. You should now be able to compile your application.

Andreas @ Embedded Artists