USB serial port driver problem

This forum topic has been closed.

09 Oct 2010

I installed the mbed USB serial port driver onto a Windows 7 64bit PC. It shows up under Windows Device Manager as "mbed composite device" in the "Other Devices ?" category. When I run Tera Term it is not possible to select it, and the serial port radial button remains greyed out. Has anyone else tried this on a Windows 7 64 bit PC? Suggestions?

10 Oct 2010

How high does the TeraTerm program go in serial port number?
When I used it, it would only accept 1-4... I bet that yours is a little higher than that?

Lerche

11 Oct 2010 . Edited: 11 Oct 2010

I've used it on Windows 7 64bit. The port number is not the issue. When I installed it, it showed up as com port 11. This wasn't an issue with TerraTerm, but it was an issue with some other terminals. If you can't see the port in TerraTerm, then the port probably doesn't exist on the system. You should also be able to see it as a serial port in device manager. Try re-installing the driver, or a different USB port.

11 Oct 2010

Thanks for confirming that it works on 64bit Win7. I tried a 32 bit XP system and everything was fine. I agree that the windows port doesn't seem to be correctly configured. I tried the re-install but no success. I will remove the non-working driver, and try to install after a minimal win7 boot (in case there is a conflict with other drivers on the system).

12 Oct 2010

Still no success after reinstallation of the mBED_Serial_16466 driver. It is not able to create the USB COMM port on my PC, which is a new Dell StudioXPS 8100 running an Intel i5 processor and Windows 7 64 bit. For some reason, the windows device manager does not display the category PORTS (COM and LPT) at all. I contacted Dell, but their support could not resolve it. Is there source code available for this driver?

17 Oct 2010

Sorry to hear you're having so much trouble. Do you have another system to test it on? Did you try a different cable? It could also be Microsoft's WHQL (driver signing..) is not letting you install the driver.. Although, I can't recall if the WHQL had a problem with the mbed when I was installing it. 

Also, are you using the SpeedBoost feature?

19 Oct 2010

I installed the Serial USB driver OK yesterday on my Win7 64 system, I have UAC set to its minimal level. Could this be your problem for installing unsigned drivers? I don't suppose the Windows Event Logs show any errors from your failed install?

20 Oct 2010

Thanks for all the suggestions. I tried the UAC to minimum...I get a popup message that the driver was installed successfully...but on another screen I see an error occured because the driver could not be located! I look in the Windows event log and find this:

Log Name:      System
Source:        Application Popup
Date:          10/20/2010 11:38:07 AM
Event ID:      56
Task Category: None
Level:         Error
Description:
Driver USB returned invalid ID for a child device (101000000000000000000002F7F049E2).

The driver works fine on other windows 7 and XP systems running 32 bit. Peter - does your 64 bit system include PORTS under device manager (i.e. does your PC hardware include serial or printer ports)? My PC has no hardware serial or parallel ports, so that this may cause trouble for the mbded serial installer since the PORTS category is missing under Windows Device Manager. The mdeb device shows up as an unknown USB composite device after running the install. The driver is from ARM, so that I guess someone at ARM should be able to confirm this error?

I can use other PCs...so this is not a critical issue just and inconvenience.

21 Oct 2010

I do have PORTS in device manager. Although my PC has no real RS232 ports I had already added a USB to 2 RS232 adapter and a GPRS dev kit which also has a virtual COM port.

With the mbed plugged in I see

Disk drives - mbed Microcontroller USB Device
Portable Devices - MBED
Ports (COM & LPT) - mbed Serial Port (COM7)
Universal Serial Bus controllers - mbed Composite Device

The driver I used was mbedWinSerial_16466.exe from somewhere around here

12 Mar 2012

I too have this difficulty however only for some MBEDs.

Some of my MBEDs connect and are visible on Explorer window in Windows7 64 bit but not all of them.

All of my MBEDs connect and are visible on Explorer window on XP 32bit.

On the W7 machine, the device is connected (I can hear it and it is visible for TeraTerm and it can be 'ejected') however it does not appear on the Explorer window so I cannot drag programs to it.

I did copy over the MBED.htm file from a working MBED(on W7) to a non working MBED(on W7) using a WXP machine. Still no luck. I have a bunch of MBEDs that I cannot use right now. Hopefully someone has had a similar problem.

04 Oct 2012

I'm experiencing this problem right now. Same mbed on my Dell Studio 435MT, Windows 7 x64 works fine. Brought it in to the office today and on my Dell Optiplex 980, running Windows 7 x64 as well, comes up under Portable Devices instead of Ports. I'll see if I can find the driver that everyone is referring to and try to change to it.

04 Oct 2012

Hi Dave,

The mbed driver is here :

Windows serial configuration

I'm using mbed on a Win7 x64 machine (as we all do) without any issues, so I guess the problem must come down to certain configurations, options, security levels and so on.

Thanks, Chris

24 Apr 2013

Same problem here right now ...

Win7 64bit; on a I5 processor from HP one MBED works fine the other one doesn't seem to be able to communicate with my PC, nor can it be programmed.

Koen

03 May 2013

how long it takes the driver to install? after i click install, the window disappears and i've waited for 10 minutes and nothing. i have widows 7 x86.

03 May 2013

Koen Kempeneers wrote:

Win7 64bit; on a I5 processor from HP one MBED works fine the other one doesn't seem to be able to communicate with my PC, nor can it be programmed.

Koen, Catalin

You need to install the serial driver separately for each mbed. Connect the new mbed before running the installer.

The mbed should show up as thumbdrive without any installation. When this fails you may want to check the usb cable and replace it by a better quality cable. Some problems were reported with marginal cables and win7.

10 May 2013

I also have problems with mbed USB serial (mbedWinSerial_16466.exe)

I've just started working with mbed H/W (LPC1768 & LPC11U24) and it's good stuff. My biggest problem is the serial comms over USB for debug logging.

Hosting on an i5 running Win7 64 bit, I installed mbedWinSerial_16466.exe. The first 1768 I tried showed no output using TeraTerm as a client, switching to another 1768 and it worked! I'm now connected to a 11U24 and I have seen no sign of comms over USB despite a number of re-installs of the mbedWinSerial_16466 driver.

In fact it's now got worse, when I install mbedWinSerial_16466 it shows up in Device Manager as "Other devices | mbed Composite Device" with the error

The drivers for this device are not installed. (Code 28).

There is no driver selected for the device information set or element.

To find a driver for this device, click Update Driver." instead of showing up under "Ports (COM & LPT)

Any suggestions how to get comms working again, anything I can clean up in the registry etc, anything I can check at the mbed end to see that comms is working at that end?

10 May 2013

FYI, i 've solved the problem after i read an other post regarding cables. If you have a USB cable handy with RF chokes? Try that one you may find that all problems are solved. Also a shorter cable might solve your problem.

I know this sounds absurd but it worked for me..

KK

10 May 2013

Thanks for the reply. My cable is only a metre, has a choke and works fine for file transfer (i.e. as a USB drive). Currently my main problem seems to be that although the driver says it installs successfully, Windows can't find the driver files.

Strange how writing something down makes you think! I tried unpacking the installer exe with 7-zip then told Windows to update the driver and pointed it at the directory containing the unpacked archive. Then it installed correctly.

11 May 2013

Hi to all!

I was experiecing the same problems using my MBED on my home computer (Samsung series 7) with Win7 / 64bit. The driver was properly installed, I was able to see the Virtual COM port under device manager, but when i tried to establish a connection, everything stopped working (I wasn't able even to upload code through thumb drive, nor with using KEIL). Then I had to restart the PC. I was able to use USBSerial normally. I tried different settings, different cables, nothing helped. Then I tried to swich the MBED to USB2.0, and that was the solution. So, if you are trying to connect MBED to a USB3.0 and you experience problems, try with a USB2.0.

Regards,

Gorazd

24 Jan 2014

Hi Gorazd, You said " Tried to swich the MBED to USB2.0, and that was the solution. So, if you are trying to connect MBED to a USB3.0 and you experience problems, try with a USB2.0 "

Please explain more step by step of how to swich the MBED to USB2.0 ? And my laptop has two USB3 ports on mother board, I used USB2 cable and did not work !

Thanks Daniel

22 Jun 2014

Man this was a tough nut to crack.

I had tried everything on these forums and eventually fixed my problem.

I had to uninstall all the mBed drivers, delete the oem*.inf and *.pnf files. Delete ghosted devices by showing hidden devices in the Device Manager. Remove registry entries in the serial comm folder.

Eventually I found that I could manually add comm ports In device manager. I then went 'Action>Add Legacy Hardware>Install the hardware that I manually select from a list (Advanced) Under Common Hardware Types selected Ports (COM&LPT) Selected (Standard Port Types) and Communications Port and proceeded to install it.

I then changed the default COM3 port number manually from the default value of COM3 to COM4 in Port Settings

Plugged in the mBed and let it reinstall itslef.

Reran the serial driver

FINALLY - the mBed appeared as mBed Serial Port COM3

I then plugged in my second mBed and it is now appearing on COM5

I have no idea if any of these steps didn't actually make a difference but I wanted to list everything that I did in case it might work for you.

/media/uploads/jdavey/mbed_serial_com3_com5.png

27 Mar 2016

(INTEL Active management Technology (COM3) ) - SOLVED - When you purchase the HP 6000 Pro keep in mind this is a very powerful machine with many upgrades available ... I write this as a problem solver for those who may run into the same Problem I did recently... This machine comes standard with a (2) core CPU and you can upgrade to a Intel 2 Quad core ... BUT if you do change to a quad core you will need to know that if you reinstall an operating system with the Quad installed you will run into a major issue with the INTEL Active management Technology (COM3) Driver ... It took me four days with many tests repeated for me to finally realize I needed to keep the Dual core 2.8 E5700 installed while installing the operating system for the driver to install... After you have used a lower grade CPU with a fresh install of an Operating system you can soon after or right after Finally install your Quad core and the Driver remains with no error ...

15 Aug 2016

I found that the problem is resolved by manually setting the device driver to C:\Program Files\mbed\drivers. Step-by-step instructions are attached. Click the link below.

-Jaime

/media/uploads/jcuevas/serial_port_problem.docx

01 Jun 2017

Dear mbed,

I need your help please suggest me,

I am using the window 7 32-bit PC. Today i faced one issue that i am Using My PC port 1 than com port 1 is making. and i also tried in remaining 3 USB port than also same 1 comport is making. SO i want to know that why its making the same comport 1 in all remaining USB Port. It must be different. So please suggest me what is the issue and how i can solve this issue. i need your help.

Thank You

Ashish K Chawla

You need to log in to post a reply