7 months, 2 weeks ago.

F303RE USBAudio Library

II am trying to compile through online mbed with ST's own provided USBDevice library but im getting an error

Error: Identifier "USBHAL_Private_t" is undefined in "USBDEVICE/USBDevice/TARGET_STM/USBHAL_STM32.cpp", Line: 36, Col: 6

Does this library not have support on f303re? Is there any alternatives i can use for USBDevice capabilities on STM32 boards ?

Question relating to:

ST
A world leader in providing the semiconductor solutions that make a positive contribution to people’s lives, both today and in the future.
Comment on this question

1 Answer

7 months, 2 weeks ago.

Hi

Yes, with MBED-OS2, USB was not implemented for F303RE:

https://github.com/ARMmbed/mbed-os/blob/master/features/unsupported/USBDevice/targets/TARGET_STM/USBHAL_STM32.h

In MBED-OS5, F303RE has not been implemented. You can propose a patch in

https://github.com/ARMmbed/mbed-os/blob/master/usb/device/targets/TARGET_STM/USBPhy_STM32.cpp

in order to support it.

oh thanks. im gonna propose it. So im trying to get sound data from pc to board over USB and then ill send the data to an external DAC. Can you advice me about what i can do to accomplish this? Do we have any other libraries about that?

posted by Bora Çelebi 26 Apr 2019

Actually i tried it on f303re with CLI for sending to PC and it worked.

posted by Bora Çelebi 26 Apr 2019

Is there a ST board you would recommend on which i can program it to make audio stuff?

posted by Bora Çelebi 26 Apr 2019

You need to log in to post a question