2 years, 3 months ago.

Documentation not ready or unable to update documentation

I did not have this problem sometime ago (about 5 months ago), but now, I am trying to update the documentation of the libraries in the online Mbed compiler, however: i) For non mbed libraries, despite clicking on the "The documentation is out of date" to update the documentation, it is unable to generate the documentation ii) I do not get this message on the up to date mbed library, but I get a "Documentation not ready" message as seen below, despite clicking on the compile->update docs. /media/uploads/cpanazio/mbed.png

iii) Only the mbed-os is showing the documentation.

I have searched for this issue, but the suggested update docs procedure have not worked or there was a problem in the server that was already solved. Do you have any idea what is going on?

Thanks!

2 Answers

2 years, 3 months ago.

I have the same problem Cristiano is reporting. Any hint are greatly appreciated. Eduardo Pellini

2 years, 2 months ago.

I managed to create the documentation yesterday by first committing the changes to the project and then publishing.

Hi Craig,

I've followed your steps and it worked for the NRF24L01P library that I am using. Thanks! It's curious, because I've never had to do this in order to generate the documentation. Why do Mbed have changed this? However, despite trying to commit and publish the whole project too, I am still not able to generate the mbed library documentation and I still get the "Documentation not ready" subtree warning. This is not surprising, since it is a special library and the commit and publish options for the mbed library are not available. For the record, the program still compiles and works fine. Nonetheless, the mbed library documentation is useful for my students in my course and it makes it easy for them to search for the classes definitions, api and examples. If anyone can find a solution for this issue, I would greatly appreciate.

posted by Cristiano Panazio 19 Mar 2019