1 year, 5 months ago.

STM32F429-Disc1 not working

Hi I’m trying to set up the discovery board(STM32F429I-DISC1) with the mbed online compiler.

I used this example: https://os.mbed.com/teams/ST/code/DISCO-F429ZI_LCD_demo/

I’ve always get this error: Error: Cannot open source input file "stm32f4xx_hal.h": No such file or directory in "BSP_DISCO_F429ZI/Drivers/BSP/STM32F429I-Discovery/stm32f429i_discovery.h", Line: 48, Col: 28

I’ve also tried to install SW4STM32 and create there a new project or to export the example for SW4STM32. I’ve used this help for the installation: https://monoclecat.de/?l=stm32f429-discovery-mac-tutorial

But it still doesn’t work.

What’s the problem?

Kind regards

1 Answer

1 year, 5 months ago.

Hi Ireno,

I have just tried the touch screen demo:

https://os.mbed.com/teams/ST/code/DISCO-F429ZI_LCDTS_demo/

This compiles and works, give that a try and make sure you have your board selected (top right button on the web page) before you compile, it may be set to the last board you were using.

Thanks a lot. I didn’t know that I have to change the board :D. Now it works.

posted by Ireno Wälte 06 Mar 2019

I’m trying to create a PWM (PC_8) and calculate the frequency of the PWM-out with a FFT. When I connect the analog-input(PF_4) with the pwm-out(PC_8) I get some flickering at the LCD.

posted by Ireno Wälte 14 Mar 2019