6 years, 11 months ago.

Is this compiling correctly?

I have followed all the instructions to get eclipse up and running, and it appears to be working. However, when I build the project, all I get in the console window is:

Console:

18:38:06 **** Incremental Build of configuration Release for project FileTest ****
cs-make all deploy GCC4MBED_TYPE=Release 

18:38:06 Build Finished (took 87ms)

Which doesn't look like is explained in the notes, and I can't see any .bin or .hex files being created anywhere. I am on Windows 7 and had to copy the cs-make.exe file into the "\gcc-arm-none-eabi\bin" directory before the project would build correctly. This was even after changing the environment variables as listed in the instructions.

Any ideas? I am trying to build a .hex for the Mini-DK board.

Question relating to:

2 Answers

6 years, 11 months ago.

The FileTest project folder should contain the BIN/HEX file after compilation (works for me with Windows 7 Professional).
Did you read the entire post at http://mbed.org/cookbook/eclipse-for-building-and-debugging?
Especially, at the end, the additional notes for Windows users.

6 years, 11 months ago.

Hi Frank, thanks again for your quick reply! I did follow all of the instructions, including the additional ones. The problem I think is something to do with the make file. As the instructions state, to begin with it could not find 'cs-make'. I added the path variable '${ProjDirPath}\..\..\external\win32' as instructed, found the make file and renamed to 'cs-make'. With this configuration I still get the error saying it cannot find the cs-make program. The only way I can get it to build is to copy the cs-make file into ${ProjDirPath}/../../gcc-arm-none-eabi/bin.

This is where I am now, but I don't think it is building correctly despite having no errors.

There is still a path problem (copying cs-make into ...gcc-arm-none-eabi/bin should not be needed).

I noticed you used forward slashes in your answer above. Make sure you did not use this in the PATH variable, this will not work, only backslashes work with the PATH variable.

Are there white spaces in your path to GCC4mbed or Eclipse? If so, try installing them in your root directory (eg: i installed both on a second partition - D:\gcc4mbed and D:\eclipse)

Did you also check the 'Note' in 'Eliminate Indexer errors' on the cookbook page?

posted by Frank Vannieuwkerke 16 Apr 2013

Thanks Frank, that might have been the issue, I re-installed at a root level and followed the same steps and it worked fine! Must have been too long path names for it to handle...

I changed the slashes in a bit of desperation I think towards the end of trying! Thanks a lot for your continued help! I've now got it compiling the examples, but the board doesn't seem to be doing anything so something isn't right still! I tried the example HEX files that were linked in the notes page and they work fine. I've bit the bullet and ordered an LCP1768 mbed so I can use the online compiler anyway, so it should arrive tomorrow and hopefully sort any compiler side issues!

Thanks again for your help!

posted by Ewan Harwood 16 Apr 2013