Report
1 year, 6 months ago.

Adding Github hosted code ends up in page error

On my side this seems not to work, getting the following error page after clicking on "Add repository" (already on the "Add GitHub Repository" page):

Page error

Sorry, this page is currently unavailable.



Am I missing something?

Question relating to:

Comment on this question

1 Answer

1 year, 6 months ago.

Apologies for this Wolfgang. We'll look into why this error occurred for you and report back.

Ok, thanks. Waiting for your feedback.

posted by Wolfgang Betz 17 Jan 2018

Hi Wolfgang,

This is now resolved. We believe that you may have tried to add a private repo you don't have ownership permissions for. The appropriate messaging should now be shown.

Best, Phil.

posted by Phil Howell 18 Jan 2018

Well, I am getting now the error:

401 Client Error: Unauthorized for url: https://api.github.com/repos/ARMmbed/wifi-x-nucleo-idw01m1

But the repo is neither private nor do I have no ownership permissions for it!

You might want to involve Mihail Stoyanov in this discussion.

posted by Wolfgang Betz 22 Jan 2018

I have the same problem when trying to add a public repository. I've tried to add a screenshot of the error but seems I cannot "insert images or files" when using google chrome Version 60.0.3112.78 (Official Build) (64-bit) on Windows 10 :(

posted by Sam Grove 24 Jan 2018

Any news?

posted by Wolfgang Betz 08 Feb 2018

Hi Wolfgang, we are currently putting out a fix to show a more meaningful error message on that form. In the meantime could you try re-connecting your GitHub account via https://os.mbed.com/account/settings/ and trying again?

Best, Mike

posted by Michael Quested 08 Feb 2018

Seems as if I am not considered being the owner of this repo:

"You must be the owner of the repo you are trying to add."

This might be due to historic reasons as - as far as I remember - at the time of creation of the repo we needed to ask Mihail Stoyanov to do this for us (STM) in order to get it public under ARMmbed. This is in part also the reason why I asked in another post if you are planning to make this new feature also available for team profiles. Is there any way/possibility to work around this "owner" restriction (at least in this case)?

posted by Wolfgang Betz 15 Feb 2018

To post an answer, please log in.