3 years, 6 months ago.

VT100 emulation in Linux

Hi there,

I am trying to play with the repository [lorawan-demo-72](https://os.mbed.com/teams/Semtech/code/LoRaWAN-demo-72/) using my linux computer. Everything seems to be ok, I can connect to my node:

http://www.st.com/en/evaluation-tools/p-nucleo-lrwan1.html

But there is something wrong with the vt100 emulation because I cannot see the proper ouput, this is what I receive in my terminal:

/media/uploads/jgato/screenshot_from_2018-01-03_16-34-57.png

Instead of this one:

/media/uploads/jgato/main_screen.png

Similar issue using coolterm

/media/uploads/jgato/screenshot_from_2018-01-03_17-24-19.png

It seems the typical encoding issue but I dont know how to solve it.

Looks like a BAUD rate setting

When starting minicom use the -s switch to change settings i.e. > minicom -s then option 'E' and set to 115200 8N1 as per LoRaWAN example

from your screen shots you seem to have 9600 baud rate set not 115200 Hope this helps....

posted by Martin Simpson 03 Jan 2018

Yes, it worked like a charm!! 9600bauds worked well with other examples...

posted by Jose Gato Luis 05 Jan 2018

It seems now the result is better I dont get too much information, maybe because I have done something wrong. I have the configuration for public, over the airc, and the application euir and applicatoin key:

#define LORAWAN_DEVICE_EUI                          { IEEE_OUI, 0x44, 0x55, 0x66, 0x77, 0x88 }

#define LORAWAN_APPLICATION_EUI                     { 0xcb, 0x4f, 0x12, 0x49, 0x9f, 0x32, 0x37, 0x3b }

That corresponds to my network server in a Multitech Conduit mlinux version:

"network": {
                "public": true,    /* set to false for private LoRa network with
                "eui": "cb4f12499f32373b", /* 8 hex byte */
                "key": "943ac2f9df30a24a84aa6ecb2a36ccbe", /* 16 hex byte, netwo
                "leasetime": 0  /* time until mDot join expires (minutes) or 0 f
        },

But nothing happens in the output of the lorawan-demo:

/media/uploads/jgato/screenshot_from_2018-01-05_12-55-58.png

posted by Jose Gato Luis 05 Jan 2018

After some work digging with the gateway:

http://www.multitech.net/developer/forums/topic/stm32-with-conduit-network-server/#post-22260

I am not sure if the node is transmitting something, or in which frequency. The TerminalEmulator dont say too much information :(

posted by Jose Gato Luis 09 Jan 2018
Be the first to answer this question.