2 years, 10 months ago.

usb drive crashes after dragging file

I can get the LPC824 to show up as a drive letter in windows just fine.. but when I drag a "bin" file to the drive it shows up for a few seconds then the drive letter disappears and then comes back but with no bin file written to it. The usual "mbed.htm" and "details.txt" are there.. I even I tried this on multiple machines... I even updated the firmware (which went well)... still have the same problem.. Too bad I ordered several of these things thinking they would work for my purposes... they appear to have faulty firmware.

It also appears to be a file size thing. If I create a file directly on the device then its fine... but If I grow the file beyond a certain size the system crashes again.. and the file is gone.

One time, I even got a new file called "FAIL.TXT".. that contains the text "An error occurred during the transfer"

any ideas?

Question relating to:

The Switch Science mbed LPC824 operates at CPU frequencies of 30 MHz. The LPC824 includes up to 32 kB of flash memory, up to 8 kB of data memory, four …

2 Answers

2 years, 10 months ago.

It is normal behaviour for the file not to show up on the drive. It will be flashed into the target right away. Note that only the original lpc1768 and lpc11u24 have a local flash memory on the mbed to store the bin files as if it were a usb memory stick. The lpc824 has only a small flash memory. Check the bin size and memory size in the compiler window to make sure it fits or it will not execute. Test the flash function with the mbed_blinky example.

I get what your saying... I tried again with blinky code, I compiled, dragged it to the drive... drive went away... I disconnected USB, then reconnected USB... but no blinky LED... blinky bin file is pretty small, about 8k

posted by Errol Burrow 10 Nov 2017
1 year, 6 months ago.

Recently bought one LPC824. Blinking an LED & using the I2C feature works, but only for about 20 secs, then the module hang. I am convinced this product is faulty,. Problem could be firmware or hardware or both. I am switching to LPC1768 module by mbed.

My code for blinking an LED.

  1. include "mbed.h"

DigitalOut myled(LED1);

int main() { while(1) { myled = 1; wait(3); myled = 0; wait(3); } }

The LED1 blinks correctly, but hang up after about 20 secs.

Have you tried your code on your other boards? and if you post your code here we can look to see what is happening.

posted by Paul Staron 09 Mar 2019