4 years, 1 month ago.

K64F no longer mounts in Mac OS X 10.11 / 10.12 ?

I had been working on some projects with mbed & the K64F successfully on my Mac a few months ago (board mounted, copied & ran .bin's fine). Today after a long delay, I tried again on 10.11 El Capitan and 10.12 Sierra and find that none of them mount when plugged into USB.

- Tried with 6 different boards (2 factory fresh from the distributor) and 2 different Macs.

- LEDs come on and the programs that were already on there successfully run.

- They don't mount in regular mode OR in bootloader mode.

- No weird errors in Console.

What should I do? Google tells me that previous version of OS X did mess up mounting the virtual mass storage device. That bug looks like that was fixed, is this a new bug in new versions of OS X? Or something else gone wrong? Has nobody tried this on a Mac since 2014?

If a new/updated firmware is required, a) where should I find one? (looks like 0243 from DAPLink is the latest? - if I had to guess these all have 0221 or 0220), and b) how do I actually get it on the board if I can't mount it in BOOTLOADER mode?

Sorry if this is a dumb question, but I'm stumped, and I'm in a pickle since I'm now in a crunch to get this project finished.

Thanks, Loren

Question relating to:

The Freedom-K64F is an ultra-low-cost development platform for Kinetis K64, K63, and K24 MCUs.

1 Answer

4 years, 1 month ago.

Hi Loren, This sounds like an issue with the host side setup. Please try the following:

  • 1. Try a different USB cable
  • 2. If the drive enumerates, then issues the following commands (this removes any issues with drag and drop functionality on OS X):

     $ sudo mount -u -w -o sync /Volumes/BOOTLOADER
     $ cp -X <path-to-interface-firmware-file> /Volumes/BOOTLOADER/

Note: "BOOTLOADER" should be replaced with name of the disk detected on your Mac

The recommended DAPlink interface firmware is available for download here - http://www.nxp.com/assets/downloads/data/en/ide-debug-compile-build-tools/0243_k20dx_frdmk64f_0x5000.zip

If nothing works, I'd recommend giving it a try on Windows (7/8/10) PC

Accepted Answer