Report
8 months ago.

Trouble communication with beagle Bone

Hello, I wrote a code that is supposed to get a 4 character instruction in order to controle solenoids/pumps/read information from sensors on my NucleoF303K8. I tried it on CoolTerm with USB communication and it worked well. But now my nucleo is supposed to communicate with a beagle bone card (which sends the instruction to my nucleo) via serial port using Putty (PA_9,PA_10) and it is not working anymore: and i don't know why. Can somebody help me please ? Thank you very much, Yann.

Here is the code: /media/uploads/yanndb/main.cpp

Comment on this question

1 Answer

8 months ago.

Have you confirmed that the Beagle Bone serial port is working ok ?

Check the Beagle Bone with your USB serial dongle - be sure the voltages are compatible with each other. From a quick review, the Beagle Bone is operating the UART @ 3v3 (ie. NOT RS232) so be sure the USB dongle is also 3v3 compatible.

Use minicom or similar tool on Beagle (Linux) to send out data -> confirm the USB dongle can view this data.

Check the baud rates, UART parameters between the interfaces - must be the same.

Also, that your TX is wired to remote RX and your RX is wired to the remote TX. Disable hardware flow control on the Beagle Bone since you are not using RTS nor CTS handshake lines.

Enable the print code to view what the mbed is receiving from the remote PC.

pc.printf("%c", ch);

update #1

consider to use the better buffered serial port library on mbed and try again. Please post your results.

https://developer.mbed.org/users/sam_grove/code/BufferedSerial/

I tried again, but even if all parameters seem ok, it only takes in account the first instruction and doesn't work with second one. Do you think there is a problem with a buffer ? Or somethign else ? Thank you.

posted by Yann De Baudus 20 Feb 2017

To post an answer, please log in.