5 years, 7 months ago.

Online build system broken???

Something changed in the online compiler within the last few weeks that's causing projects built for an LPC11Uxx using mbed-dev to break. I tried to resume work on one of my projects that's using a local copy of Rev 153 today, but the binary size has jumped substantially out of the blue, and as a result the project no longer links. I tried an experiment using the blinky template for an mbed LPC11U24, and the mbed-dev version was a whopping 5.9kB larger than the mbed binary version and failed to run. I checked the build macros to see if the toolchain had changed, but they still specify ARM micro.

Binary Version

/media/uploads/neilt6/mbed_build_size.jpg

Source Version

/media/uploads/neilt6/mbed-dev_build_size.jpg

Neil,

Thanks for getting touch.

What happens if you roll back mbed-dev to older revisions?

Regards,

Andrea, team mbed

posted by Andrea Corrado 06 Feb 2017

Hi Andrea. I rolled back to Rev 150 and got the same results: a massive blinky binary that doesn't run on the LPC11U24.

posted by Neil Thiessen 06 Feb 2017
Be the first to answer this question.