2 years, 10 months ago.

Online IDE's export function doesn't work now

Dear staff,

Now I'm trying to export a sample project "mbed-os-example-blinky" to my MDK-ARM environment. But, it doesn't work and stops with error dialog /media/uploads/kojima/export_failed.png The sample I'm trying is targeted for Nuvoton NuMaker-PFM-NUC472.

What is wrong ?

Comment on this question

1 Answer

2 years, 10 months ago.

I saw that this target only support to export as uVision4 project but not support Keil uVision5, could you share more about your case? /media/uploads/terencez/0109.jpg /media/uploads/terencez/0109-2.jpg

Thank you for your report.

You have ever suceed in 'export' of your code for Kinetis K64F for uVision5.

But, unfortunately, my environment and target are not what you've done.

I did it targeted for LPC11U24 also just for test, but still no success. I did the same on another PC on which uVision 5.14.0.0 is installed. In this case, I tried to choose uVision5 as you suggested, but not allowed. In this case I could choose DS-5, so I tried to do it for DS-5. But, again, no success of exporting...

When I changed target for mbed LPC1768, then I cound choose uVision5. I hoped, but again 'export'ing was failed... Sigh....

posted by Shoichi Kojima 11 Jan 2017

Let's double check something to locate the issue: 1. Seems like all export operation will be fail in your environment, what ever the platform and target selected, right? 2. How did you import “mbed-os-example-blinky” into online compiler? can you delete it and try to import again? (avoid to miss some files in the project)

Just let you know, The local tool installation do not impact the export feature.

posted by terence zhang 11 Jan 2017

You need to log in to post a question