3 years, 3 months ago.

Compiler malfunction

Compiler isn't reporting errors and only works once. I have to refresh the page to get it to work again!

I have same problem since 1hour. If no error then it creates the hexfile but compilation is ongoing infinite....

posted by Thomas Lorenz 05 Sep 2016

same...

posted by STANE ABRAM 06 Sep 2016

This has started in my case this morning 04/11/16. Can anyone tell me what to do?

posted by Som SUNDER 04 Nov 2016
Comment on this question

20 Answers

-deleted-
3 years, 3 months ago.

Hi All,

Thanks for reporting this.

The compile service was running below it's maximum capacity. We've fixed it and all services should be now running without lag/delays. Apologies for the inconvenience this may have caused.

Cheers,
Mihail

Hi Mihail, could you also take a look at the 'service status' page. That page is not getting any updates. The last check seems to be '8 days ago' and the timeline says oct/nov (probably last year).

posted by Wim Huiskamp 06 Sep 2016

Thank you so much for solving this problem. I really appreciate it :)

posted by Nazmus Sahadat 09 Sep 2016
3 years, 3 months ago.

HI, i am also having issues with the online compiler. The compiler is stuck on the initialization stage. please see image for a better explanation. Only twice did the download dialog open to download the .bin file, but the initialization window still remained open. Now, the initialize window remains open without the download dialog. Is the mbed team working on the web compiler? /media/uploads/d0773d/2016-08-29_18_21_16-mbed_compiler__main.cpp.png

I'm having the same problem. Looks like I'm done for tonight. Last year there was a similar thing.

posted by Adrian Adamson 30 Aug 2016

I have the same problem.

posted by Conrad Gagner 30 Aug 2016

Have the same problem in any web browser - noticed that there were some Microsoft updates in my history log about the time this started. Is it working on MACs?

posted by jim hamblen 06 Sep 2016

I don't know if this has anything to do w/ it, but I'm aware of [url=https://www.domyhomework4me.net/]do my homework for money[/url] least twice that certain schools within the University faced accreditation problems.

posted by Michael Fox 18 Jun 2018
3 years, 3 months ago.

I have the same problem too. I mean the Initializing window.

Today 05.09.2016 again. Really annoying. No information.

3 years, 3 months ago.

It's fixed for me now. Must have been something on the back end. It would be nice if the mbed folks would post some sort of announcement if the compiler goes off-line.

3 years, 3 months ago.

Same again now.

3 years, 3 months ago.

It's not working for me either.

3 years, 3 months ago.

Down for me too - really annoying ... any advise?

You could always compile offline...

posted by Richard C. Glover 05 Sep 2016
3 years, 3 months ago.

same for me, not compiling

3 years, 3 months ago.

Same here...

3 years, 3 months ago.

Same also

3 years, 3 months ago.

Same here!

3 years, 3 months ago.

i can compile older proyects but just that, is there any word from support people yet?

Is there ever any word from support people on here?

posted by Brendan C 05 Sep 2016
3 years, 3 months ago.

Seems like that you can compile a project if the code doesn't have any errors. With errors in the code either you need to manually figure out what is wrong or wait for the compiler to get fixed.

I figure that too... it seems the solution by now is to compile with our own eyes...

posted by Luccas Casagrande 05 Sep 2016
3 years, 3 months ago.

not working

3 years, 3 months ago.

Same problem. bin file is generated, but compiler keeps initializing.

3 years, 3 months ago.

Same problem under Chrome, Windows 7. I tried to exit chrome and comeback, exit windows, restart computer and also delete cache memory, nothing is working. !!!

3 years, 3 months ago.

Still not working unfortunately.

3 years, 3 months ago.

Same here

It looks working now. There is no problem so far. Thanks.

posted by Tatsuro Sato 06 Sep 2016
3 years, 3 months ago.

Seem like they have update online compiler recently and that causing this problem. I have encountered this problem too.

3 years, 3 months ago.

Is it fixed? I can load the codes and save modification. But it can't compile. Stuck at initialising...

Not yet. The export feature still works so for those who need the compiler, you can just export your project to another toolchain such as Keil uVision4. I believe the evaluation version is limited to 32k but useful nevertheless. This is what I am doing at the moment.

posted by Osama Ashaikh 06 Sep 2016

Seems like its been fixed as of 07:47BST 06/09/16

posted by Osama Ashaikh 06 Sep 2016

Thanks for updating. Yup it seems to be working now.

posted by Cheng Khoon Tan 06 Sep 2016

It appears so. Yet still very disappointing that there has been no communication about this issue from the mbed developers. All of which underlines the importance of having an off-line fall back for any serious work based on mbed.

posted by Ron Segal 06 Sep 2016

I don't know if this has anything to do w/ it, but I'm aware of <a href="https://www.domyhomework4me.net/">do my homework for money</a> least twice that certain schools within the University faced accreditation problems.

posted by Michael Fox 18 Jun 2018