1 year, 2 months ago.

Bricked ST-link on Nucleo 401


I think I bricked the st-link on the nucleo 401. Is there any way to restore this firmware?

I tried to replace the st-link with j-link firmware. when I restored the original firmware I see that I cannot connect to st-link anymore even though the interface enumerates as an mbed drive.


Question relating to:

Affordable and flexible platform to ease prototyping using a STM32F401RET6 microcontroller.
Comment on this question

1 Answer

1 year, 2 months ago.

If it enumerates, it is probably not as bricked as you think it is.
You may need to unplug the nucleo, reboot the PC and plug the nucleo again.
If it does not work, I recommend to reinstall the driver and eventually use the upgrade tool from here or from the ST-Link menu of the STM32 ST-Link Utility to upgrade/reprogram the firmware.

Thanks, I fixed it by uninstalling the driver from Device manager twice. Apparently the first time was not successful.

posted by Dimiter K 21 Jul 2016

To post an answer, please log in.