Report
3 years, 3 months ago.

STM32F429I-DISC1 can not be powered by using ext. USB Battery

Hello, I purchased a STM32F429I-DISC1 ev board (I know it uses the ST-LINK/V2-B debugger) , I have a graphical app running on the board (developed by IAR EWARM). I'm able to power-on the board (and to see the app running) by connecting the board to PC using USB Cable; the app doesn't run if I connect an USB Battery to the ST-LINK/V2-B USB connector, the display is white. Are there some limitations on the ST-Link/V2-B HW interface ? I tried to power-on the board using the USB-USER Port (on the other side of the Board respect the USB ST-Link port) but it doesn't work. Using the old version of the Board: STM32F429I-DISCO I was able to power-on the board by using an external USB Battery. Is there a workaround ?

Thanks Massimiliano

Question relating to:

The STM32F429 Discovery kit (STM32F429I-DISC1) allows users to easily develop applications with the STM32F429 high-performance MCUs with ARM®Cortex®-M4 core.

Problem solved updating the ST-Link/V2 firmware.

posted by Massimiliano Curti 13 May 2016
Comment on this question

1 Answer

3 years ago.

Some one on the ST Forum was complaining this wasn't answered, but I can see you posted that you solved it.

There is/was a known issue with the ST-LINK firmware shipped with the F429I-DISC1 and F407-DISC1 boards, and perhaps others. The STM32 is held in reset by the debugger when not attached to a host computer, so charger/battery use cases failed. This can be remedied by updating to current firmware revisions, at the date of posting I'd recommend downloading the ST-LINK Utilities v3.9.0 and using that to update the firmware, this has solved issues I've seen with this.

Regards, -Clive


You need to log in to post a question