4 years, 10 months ago.

nRF51 DK - not possible to flash files to the board

Hello guys, i'm new in nRF51 DK board, and i would like to flash the .hex file to my board, but when i do it the board automatically unmounting himself and reset with the following file: fail.txt which contain the "CORRUPT FILE" message. If i copy the binary file i got the same problem or "OUT OF MEMORY" message.

I have the same issue with my own build files which made by mbed yotta, and the mbed online compiler.

Somebody has any suggestion?

Question relating to:

The nRF51 Development Kit is a single-board development kit for Bluetooth Smart, ANT and 2.4GHz proprietary applications using the nRF51 Series SoC. This kit supports both development for both nRF51822 …

Could you update the firmware to latest JLINK firmware from Nordic? That's how it comes out of the box, so basically resetting it to original state: https://www.nordicsemi.com/eng/nordic/download_resource/52276/5/91880143.

posted by Jan Jongboom 20 Apr 2016

I tried with this firmware, but the i get the same problem.

posted by Levente Orban 21 Apr 2016

Is it possible to nRF51-DK doesn't enable the mbedOS ( mbed version of 3.0 ) ?

posted by Levente Orban 26 Apr 2016

If it doesn't work with the JLink firmware you should contact Nordic support. It could be the board is defective.

posted by Eirik Midttun 09 May 2016

1 Answer

4 years, 1 month ago.

Although my issue was different, but I was looking for a way to kind of factory reset and the link posted by Jan Jongboom worked fine. Thanks, Jan.