5 years, 2 months ago.

I can't copy hex to Mbed

my OS is windows 7 (64bit).

Question relating to:

Arch Link is an mbed enabled development board based on Nordic nRF51822 and WIZnet W5500 ethernet interface. With Arduino form factor, Grove connectors and micro SD interface, it is extremely …

3 Answers

5 years, 1 month ago.

There are two types of drag-and-drop involved:

When you see the drive CRP_DISABLED this means the board is ready to update the firmware for the programmer part. The programmer is the LPC11U35. The drive will have one file called firmware.bin. Delete that file and drag-and-drop the 'lpc11u35_nrf51822_if_mbed20150604.bin' file onto the drive. After completion of the firmware update you will again see a file named firmware.bin.

Now restart and return to the mbed programming mode.

You should then see the mbed drive. The only files on the drive are mbed.htm and details.txt. Ignore those. Compile your source code for the nrf51822 and drop the resulting .hex file onto the mbed drive. That file will be flashed into the target nrf51822 by the onboard programmer (ie the LPC11U35). When the flash phase is done the mbed drive will NOT show the hex file (the programmer part does not have any real storage capability, the hex file is already in the nr51822 flash memory). The fail.txt may be inspected if any problems occurred during the flash process. Reset the board and your application should start executing.

Accepted Answer

For me it is not showing CRP_DISABLED drive to update the firmware. I pressed reset button and connected to computer using usb. That didn't help

posted by Jehova Honey 21 May 2018
5 years, 2 months ago.

Mbed is expecting a .bin file. . the online mbed compiler generates that bin file for you and puts it in your default 'download' folder. then you do a drag and drop to the mbed folder (created when you plug in your mbed device). Not sure of your source of the hex file so a utility program (hex2bin) may or may not make a usable bin file.

5 years, 2 months ago.

Joseph,

For BLE we use a .hex format, so you have the correct file type. Have you tried updating the firmware on your Seeed Arch Link board? Can you describe the problem in more detail so we can try to help you?

-Austin Team mbed

I drag and drop the .hex file into the mbed drive I can copy .hex file to the disk, but can't save changes to files on the disk. It seems that mbed drive is read only

So, I have tried to update firmware but it seems to fail. I delete firmware.bin , and then copy 'lpc11u35_nrf51822_if_mbed20150604.bin' to CRD_DISABLED drive, but reboot it again the firmware.bin is still exist (the name is same with 64k in size and the file timestamp is same ) It seems that CRD_DISABLED is also read only.

posted by joseph chen 16 Apr 2016

I try to use Win7 (64bit) and WinXP, but the situation is same. I found CRD_DISABLED drive is writable, because I cant put the "Seeed Arch BLE" firmware. In the Mbed Driver, MBED.HTM and DETAILS.TXT will appear, and when I open MBED.HTM it will link to the page of 'Seeed Arch BLE', instead of 'Seeed Arch Link'

However, the Mbed Driver is still in read only. mode. ......so , what's wrong with that ?

thank you for your help and quick response.

posted by joseph chen 16 Apr 2016