Report
2 years, 11 months ago.

C027 still having trouble with Windows 10

I still can't do any C027 development on Windows 10. When I plug the C027 into the USB port, it just endlessly cycles through the following: 1) USB enumeration (drive mount) 2) RED LED (MSD) flashes for a long time (around 32 seconds) 3) USB de-enumeration (drive unmount)

I've tried updated the driver (no difference). I've tried other Windows 10 machines (no difference). I've tried Window 7 (works fine). I've tried different cables (no difference). I've tried disabling anti-virus software as was suggested in a posting I read (no difference).

I have found very little on this problem via web search. I'm not sure were to turn for help. It has been difficult to find anyone to take ownership of the problem (i.e. Microsoft, uBlox, mBed, etc...), and I'm not sure what tools are available to diagnose the problem.

Comments or suggestions?

- Update -

Discovered that the boards we have been receiving from uBlox all have the oldest firmware. (I'll reserve my comments on that policy.) Anyway, now that the firmware has been update to the latest release (Apr'14), app loads on Windows 10 are now possible, but not as pleasant as on Windows 7. Upon tethering to the computer, units still go through steps 1-2 above, frustratingly blowing away any app already loaded in flash. Then there is a fair chance that I can download apps to the unit. But, sometimes the units don't respond after step 2 and I have to repeat the process [disconnect USB, re-connect USB, wait 40 seconds for the RED LED to stop flashing, see if I can download a new app] until it works.

Question relating to:

The u-blox-C027 is a complete starter kit that allows quick prototyping of a variety of applications for the Internet of Things. The application board has a MAX-M8Q GPS/GNSS receiver and ...
Comment on this question
Be the first to answer this question.

To post an answer, please log in.