7 years, 3 months ago.

MBED USB Drive not showing up, Status LED on

I've been trying to use an LPC1768 board in this robot buggy prototype that I'm using, yet the I've had 2 mbed boards fail so far after working initially.

1) First mbed board: Worked well for a while, but then the USB drive stopped showing up. At the time of failure mbed was powered 9V by an external battery and the USB cable was attached.

I figured it might have been because the board was being powered from two sources, however

2) Second mbed board: Board was just being powered by a USB cable. Was sending 2 PWM signals to 2 servo motors that were powered externally (NOT from board). Worked well for a long time, and then suddenly the USB drive stopped showing up.

Both boards currently have the same problem - the status LED lights up when I plug in the USB cable but the USB drive doesn't show up. The first mbed still runs the previous program (a blinky) that was last loaded onto it.

Please suggest on what's causing the issue repeatedly and how I can resolve it?

1 Answer

7 years, 3 months ago.

Any chance they have had some ESD damage?

These are static sensitive devices, it you don't take precautions then they can get fried.