5 years, 1 month ago.

Usb serial does not work with 401re

Hi, No matter what I do , I cannot install usb serial port driver for my 401re and enable serial port printings. I installed stlink8 and updated firmware, made some code for lcd and led's, everything works great, but I don't see any ports at PC so I cannot connect tera term to see my debug printings.

I also tried to install stlink9 (xp drivers), no change. Back to stlink8 and it claims that usb serial device is installed and ready to use, but no, I can't find it, it does not show any ports anywhere in device configuration or tera term. I have windows 8.1.

EDIT: Douh, don't know what I did, but when I uninstalled and installed driver once more and I now see com port correctly.

Question relating to:

ST
A world leader in providing the semiconductor solutions that make a positive contribution to people’s lives, both today and in the future.

2 Answers

5 years, 1 month ago.

The situation with Nucleo L152 and Windows 7 was the same. The serial port was not recognized. After a complete reinstallation of driver everything goes well.

5 years, 1 month ago.

Have you tried this?

https://developer.mbed.org/handbook/Windows-serial-configuration

Regards!