8 years, 1 month ago.

compiling error

hello i thing there is a problem. because i added f746ng LCD ts test program and i compiled it. but does not working on f746 disco kit. i tried it 2-3 days ago. when it was working well. thanks

Question relating to:

Basic demo showing how to use the touch screen present on the DISCO_F746NG board disco, Touch Screen

Hello, I have the same problem with the F746-disco. My actual program, which i'm working on, produces a compiler L6218E error.Nothing was changed but this error appears. And none of my old programs works after new compiling, but the old .bin-files does. I think there is something wrong !

posted by Stephan Gerhardts 12 Jan 2016

1 Answer

8 years ago.

I'm sure this demo worked fine for me, but for an unknown reason if I recompile a new one it doesn't anymore. I know for sure It worked because I did not use the board for a few months and it was loaded with the LCD example when I powered the board one hour ago. Right now none of the binaries I'm producing targeting DISCO-F746G are running, the board simply refuses to run. To make sure the target is still alive I loaded the DEMO which come with the board when was shipped using ST-Link and the DEMO works, so the target is fine. It must the mbed environment I guess. Anyone else experiencing the same problems? Aurelian PS. - I powered the board from an external power supply, no joy, same behaviour.

After switching the mbed libs to newer version all seems to work again - (switched to rev. 114) good luck everybody. A

posted by Aurelian Lazarut 23 Feb 2016

I'm having same problem: Newer MBED library (rev. 115) compiled programs are not not running. But when reverting to rev.114 it works.

posted by Frans Korhonen 14 Mar 2016