Report
2 years, 11 months ago.

Dead MBED

Hi all,

Sorry for another one of these but I am stuck as to what to do!

So I was having trouble with my MBED hanging before downloading a compiled program, and eventually i would sit and wait a minute and the LED hadn't flashed. I tried several times but it appeared that the thing had stopped working.

The next thing I did was to download to my downloads folder and try to copy the files across manually.

When i tried to select the mbed folder (which was present as usual) nothing happened, it went orange to show it was selected, and then unselected itself straight away again.

It acts like it doesn't work anymore!

So I formatted it (Fat 32) and then did the unplug - hold button - plug in - release button trick, and it returned to the same state as before i formatted it except it was now called MBED again.

The weird bit comes that when i type fdisks -l into a terminal, the computer recognises it and its location and its size.

How strange.

I am using Ubuntu 15.04 on a machine with Intel i5-5200U (Broadwell) CPU @ 2.20GHz x4 I have had no problems of this sort before, and nothing was changed between it working and not working. The new program that I tried to download was very similar to the old one, small and trivial, I have tried a hello world lcd program (I am using the application board) and still nothing.

If any one could come the rescue it would be much appreciated!!

Conduit (DTH4)

Comment on this question

1 Answer

2 years, 11 months ago.

Read carefully the procedure for Linux https://developer.mbed.org/cookbook/deadmbed
This is what fdisk write about a Mbed 1768: there is NO partition

Disk /dev/sdc: 2 MB, 2097152 bytes
1 heads, 4 sectors/track, 1024 cylinders, total 4096 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System


The format instruction is for a fat12!
I use Xubuntu , there are GUI programs for disk operations but I prefer to use the command line tools to recover a dead mbed ...I have done this several times !


To post an answer, please log in.