4 years ago.

After driver installation the flash-drive will not appear

Dear Support-Team,

now I have bought this board, because I would have a more powerfull one than the arduino. The first start seems to be not so easy for me. After installing the ST-Link-Driver (DriverVer=12/10/2013,1.0) on Windows Vista x64 Business SP2 the Flash-Drive will not appear. An update of the firmware was successfull. In the usb-hardware-tab by the clock will shown "ST-Microelectronis STLink dongle". On the Harddiskmanagement in the tree of the Device-Manager also no disk without drive-letter will be shown. Does the board not support this feature? How can I upload a programm there? There are also two Micro-USB-Connectors. Must I use one of them?

Best regards, Ulf

Question relating to:

ST
A world leader in providing the semiconductor solutions that make a positive contribution to people’s lives, both today and in the future.

1 Answer

4 years ago.

Hmmm...this sounds like a driver problem. You might try uninstalling all the drivers and trying again. Or it could be related to usbstor.sys. Here is an article on the problem: https://ckon.wordpress.com/2011/04/08/windows-usb-problems-usbstor-inf/

Hello Bill, thank you for response. All USB-Sticks will be detected without problems. In the details I also see the file winusbsys in version: "6.1.7600.16385(win7_rtm.090713-1255)". I also have some old Blackberry-Software on my system wich creates RIM Virtual Serial Ports as COM3 and COM4. I will remove them now and try again.

posted by Ulf Böhme 17 Nov 2015