7 years, 1 month ago.

Compilation error on MCR20A connectivity test program

When I try to complie the mcr20a connectivity test program, I get a compilation eroor saying fsl_os_abstraction.h not found ... This is just one of the errors.. Many other fsl files are unavailable

Question relating to:

5 Answers

6 years, 7 months ago.

I'm also trying to compile the phy layer for the mcr20a chip. I'm using the FDRM-KL46Z development board . I tried using the online compilator and platformio IDE and both are giving me the fsl_os_abstraction.h not found error. It already compiled for the Kf64 with no problems but since I've only got one Kf64 and one KL46z i can't really test the transceiver =/.

6 years ago.

I have the same issue, is this not solved yet?

6 years ago.

I'd suggest getting started with the MCR20 driver that works with the mbed OS 6LoWPAN stack. Here is the phy driver and an example programs to get started from.

Examples - https://developer.mbed.org/teams/mbed-os-examples/code/mbed-os-example-mesh-minimal/

PHY driver - https://github.com/ARMmbed/mcr20a-rf-driver

6 years, 7 months ago.

Based on the history of fsl_os_abstraction.h it seems to only work on K64F...

6 years, 8 months ago.

I have the same issue. Does anyone know how to solve this?