5 years, 5 months ago.

Firmware update fails

I am unable to update the firmware to get the the MBED interface working.

I can set the board into bootloader mode, but after copying the file to the BOOTLOADER disk and recycling power, no disk shows up.

I first tried this on OS X Yosemite: cp -X 20140530_k20dx128_kl46z_if_opensda.s19 /Volumes/BOOTLOADER/

Then I tried on Windows 8.1, copying the file with Explorer.

The result is the same: No MBED disk appears.

PS: I am assuming that this part of the instructions are incorrect: "Make sure to unzip before copying to the disk called BOOTLOADER!!"

The file available for download on the firmware page is _not_ a zip file, but appears to be the binary file.

Question relating to:

1 Answer

5 years, 5 months ago.

Try it on a windows 8.0 or earlier PC. Sadly I think the bootloader Freescale is shipping them with is still not functional on anything else. As soon as the mbed firmware is on it it will work on others (although I did read something about issues with latest OS X, but not 100% sure, didn't look into that).

Accepted Answer

It worked properly on Windows 7.

I am aware of the issue with mbed on OS X Yosemite: https://github.com/mbedmicro/CMSIS-DAP/issues/69 As far as I can tell has not yet been fixed for the Freescale boards.

posted by Per J. G. 30 Jan 2015