8 years, 9 months ago.

Have I bricked my K64F

Hi, My new Freescale K64F arrived this morning. I updated the mBed firmware as per https://developer.mbed.org/platforms/FRDM-K64F/ All working well. The builtin demo was still working, flashing each of the RGB leds in sequence.

I imported the "ShakeRGBled" program into mBed, compiled and saved it to my mBed flash drive in Windows. I pressed the reset button. The white LED comes on, but the mBed flash drive has disappeared. I have pressed reset, tried different USB ports, re-uploaded the firmware (when I hold the reset button and connect USB it does appear as a 'bootloader' drive. I can see the serial port and drive in Windows device manager...

/media/uploads/gjt211/001.png /media/uploads/gjt211/002.png

The mBed drive does not appear in Windows, have I bricked this already? I tried searching google with various keywords and couldn't find a similar problem.

Hoping I have not just wasted $60.

Thanks in advance for any help.

Question relating to:

The Freedom-K64F is an ultra-low-cost development platform for Kinetis K64, K63, and K24 MCUs.

1 Answer

8 years, 9 months ago.

Hi, from what you wrote, I think it's WIndows side problem instead of mbed/FRDM.

How about trying
(1) disconnect FRDM from your PC
(2) restart your PC
(3) reconnect FRDM to your PC

Meantime, I recommend you to connect/disconnect A-type connector instead of FRDM side micro-USB.

moto