3 years, 12 months ago.

windows 10 serial driver

Hello every one, i need for an course this year the software Tera Term, and for make this one working, i need of the driver mbed usb for Windows 10, i went to there website but after install it, it still not working. Can you help me please? Thank you for your answers.

Question relating to:

Comment on this question

5 Answers

1 year, 9 months ago.

If you're using a later version of DAPLink, the mbed serial driver is no longer for windows 10. Here are the latest DAPLink builds. https://armmbed.github.io/DAPLink/

3 years, 7 months ago.

Any idea when the mbed serial drivers for windows 10 will be launched.

I have the driver installed in Windows 10 whats the problem with your installation?

posted by Ney Palma 17 Feb 2016

It is stucked and then saying installation failed.

posted by Maninder Pal 17 Feb 2016

Have also disabled the driver signature verification and tried to install many times. But no success. It is still giving yellow mark in the device manager. If there are drivers for 64 bit machine or any method to install on 64bit machine then please let me know. It works fine on XP and 32 bit Windows 7 machine.

posted by Maninder Pal 23 Feb 2016
3 years, 8 months ago.

Hi, I've got the same problem on windows 10, I disabled the driver signature verification with following the instructions on the link Thom Bronez provided, and I still get an error when trying to install the mbed Windows serial port driver: "The driver could not be installed. No mbed Microcontrollers were found." I also tried to install the driver with compatibility mode, still got the same error message.

Please see your other post for some details and a possible work around. Also, be sure that your MBED board is attached to the PC.

https://developer.mbed.org/questions/60526/driver-for-x64-bit-machine/

posted by Sanjiv Bhatia 19 Jan 2016
3 years, 12 months ago.

Hi, did you try to install driver with compatibility mode? Do you have team viewer to help you?

Have you disable driver signature enforcement?

posted by Ney Palma 22 Sep 2015
3 years, 9 months ago.

I similarly had trouble until, as Ney Palma says, I disabled driver signature enforcement. See http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/ for guidance.

I had some trouble with the COM port numbering under Windows 10, too. After connecting your mbed hardware platform with the USB cable, go to Settings -> Devices -> Connected devices and look for the MBED COM port number. Use that in Tera Term.