6 years, 2 months ago.

driver for x64 bit machine

the driver is not installing in my Windows 10 x64 bit machine it gives a error message driver not be installed

Question relating to:

remove Windows 10 from machine it virus

posted by acr acr 01 Sep 2015

8 Answers

6 years, 1 month ago.

Hi.

same problem. I have team viewer. I wonder when you can help me? exactly time. I wait your answer.

I got this matter. you don't need to answer to me.

posted by ch kang 01 Sep 2015
6 years, 1 month ago.

Anyone has a practical solution to this problem?

Maybe i can help you vía team viewer later

posted by Ney Palma 05 Sep 2015

I have managed to get the driver installed and got a mbed Serial Port.

What I did was extract the driver file via 7zip, update the USB storage driver in Device Manager by pointing to the extracted driver folder.

posted by Cougar GTR 05 Sep 2015
6 years, 1 month ago.

Is there any updated driver fully compatible with Win10 x64?, I have already disabled the "Enforce use of signed drivers" and after clicking on install it displays "The driver could not be installed"

what a ass I wasn't connecting the damn board, anyways for those struggling with Win 10, before installing the driver check this link to enable the use of unsigned drivers: https://learn.sparkfun.com/tutorials/disabling-driver-signature-on-windows-8/disabling-signed-driver-enforcement-on-windows-8

posted by Augusto Panecatl 16 Sep 2015
5 years, 8 months ago.

Any idea when the mbed serial drivers for windows 10 will be launched.

6 years, 2 months ago.

Hi, what problem do you have?

i can't install serial drivers on windows 10

posted by suresh subramanian 18 Aug 2015

Hi maybe i can help you by team viewer

posted by Ney Palma 18 Aug 2015

Please let me know when i can help you by team viewer. Greetings

posted by Ney Palma 18 Aug 2015
5 years, 9 months ago.

Hi, I've got the same problem on windows 10, I disabled the driver signature verification and I still get an error when trying to install the mbed Windows serial port driver: "The driver could not be installed. No mbed Microcontrollers were found." I also tried to install the driver with compatibility mode, still got the same error message. Any ideas ?

Here is a potential solution / temporary work around. The issue is that the USB Serial solution is based on fixed Vendor & Device IDs that are required to be married to a signed INF driver package. If the signed drivers are found then the hardware will install on 64 bit operating systems. Respectively, if the driver is not signed, the hardware will fail to install.

Work around is to alter the Vendor & Device IDs and pair with a driver package that is signed.

The default MBED IDs are detailed here: https://developer.mbed.org/users/mbed_official/code/USBDevice/file/0e6b3f44926e/USBSerial/USBSerial.h

vendor_id = 0x1f00 product_id = 0x2012

change them to:

vendor_id = 0x04D8 product_id = 0x000A

and apply this driver package during the installation: http://www.microchip.com/forums/download.axd?file=0;796940

Can confirm that this solution works for another target micro for some lab tests conducted last year. Should be also fine for this exercise as the serial port is an industry standard CDC model.

Moving forward, for production, you are required to use unique registered IDs. In the meantime, share the love and support the respective silicon vendor with future purchases :)

Hoping that MBED will support the same driver package with signed drivers (with MBED IDs) in the near future.

posted by Sanjiv Bhatia 19 Jan 2016
6 years, 1 month ago.

same problem

Do you have team viewer?

posted by Ney Palma 18 Aug 2015
5 years, 10 months ago.

my driver of mbed lpc1768 was installed corectly only in windows XP that's the only solution friends