6 years, 1 month ago.

About installing gcc4mbed

I think I already installed gcc4mbed to my mac pc according to this web site "https://github.com/adamgreen/gcc4mbed#quick-start"

And also I installed CDT GNU Cross Development Tools from eclipse's install new software page.

But I have two different situation. First one, in Toolchain for Indexer Settings , I couldnt see ARM Mac OS X GCC (Sourcery G++ Lite)

second one about Build (Incremental Build) from all to all deploy GCC4MBED_TYPE=Debug I couldnt see this item GCC4MBED_TYPE=Debug.

I couldnt be sure about I installed gcc4mbed correctly. How can I be sure about that ?

Question relating to:

2 Answers

6 years, 1 month ago.

Hello Kagan,

When you installed gcc4mbed it should have automatically done a clean build and would have generated an error if anything had gone wrong. The install process should have created a mac_install.log in the root gcc4mbed subdirectory. You could check it for any errors.

The install process also generates a BuildShell script in the gcc4mbed subdirectory. If you run that script then you will have a Terminal window that is able to build the gcc4mbed samples. With this terminal you should be able to go into the samples directory and issue a make clean-all all to build all of the sources again to make sure that it is able to successfully build things outside of Eclipse.

Even though I helped document the steps to install Eclipse, I don't have much experience with it myself.

I hope that helps,

Adam

Hi Adam,

I have the same problem as Kagan but i believe that the environment variables have not been set correctly as the directory I have installed gcc4mbed does not appear under the PATH environment variable. Is this correct?

posted by Michael Vowles 04 May 2015
5 years, 10 months ago.

Even I am facing the same issue as Kagan. It does not work from the terminal either :( @Kagan - were you able to solve it ?

Hello Harsh, what have you tried from the Terminal and what errors did you receive?

Thanks,

Adam

posted by Adam Green 14 Apr 2015

Hi Adam Thanks for getting back. Got that working, I was providing a wrong file path :P

posted by Harsh Jain 14 Apr 2015

Harsh what did you do to fix this? I don't think the environment variables have been set correctly. I have maded path include the gcc4mbed directory but still no luck.

posted by Michael Vowles 04 May 2015