5 years, 7 months ago.  This question has been closed. Reason: Opinion based - no single answer

mbed online compiler is not working

I clicked on the Developer Site. Than on the compiler. Now generally when i click on New or New program, nothing happens. The options are there but when i click it there is no response. i am using Win8.1, i7-4710HQ, 8G.B ram, i used it on the following browser Google chrome, Internet Explorer, Firefox please if you have a solution. My e-mail is crackpot.mustafa@gmail.com

i consulted 7 to 8 mbed officials personally and showed them this issue. and even they aren't able to solve it.

same problem here, compiler page is not responding at all.

posted by Rudresh Pandit 21 Jan 2015

Hello there,

I just received my first mbed device yesterday, this is my first time using mbed and I am having the same problem as well. I tried every browser I have and I even tried using Google Chrome in Windows 8 mode but still nothing has happened. We really need help with this.

posted by Jan Ray Rulida 28 Jan 2015

Same with me. I click on ANYTHING and then get up to get coffee or go read some web page and have to keep checking to see is (say) something changes. It is UNUSABLE

posted by Chris Albertson 10 Oct 2016

I have the problem that the compiler doesn't respond at all... Well I didn't find anything helpful on the internet and also the mbed support wasn't able to help me so I had to find another solution. I have Win10, i7, 16GB Ram btw... Maybe this helps (for those whose compiler still doesn't work): Download VirtualBox and a Win7 machine. There are enaugh tutorials on youtube for this. This worked fine for me... yeah it's a bit annoying having to start the virtual machine everytime... but it works!

posted by Ignacio Neuhaus 01 Feb 2017

9 Answers

3 years, 10 months ago.

Hi Everyone,

There are currently small issues we are having :) , we are definitely working on it.

Please if you have any of these issues and want a direct reply send me a mail at support@mbed.org :) .

In terms of what alternatives you can look at, maybe you'd like to try out mbed-CLI, which is a command line tool for offline compiling.

https://github.com/ARMmbed/mbed-cli

If you need anything, let me know.

Regards,

Andrea, team mbed

3 years, 10 months ago.

compiler is too slow to load !!

Same here

posted by Erik van de Coevering 26 Sep 2016
3 years, 10 months ago.

For a couple of days now, the compiler has been spotty in its availability. Its been occasionally becoming unavailable, but today it seems to be for a prolonged period... I have no idea why, but it seems to be a problem with the mbed compiler end, not ours.

3 years, 10 months ago.

Me too, can take over a minute to open the compiler, then another minute or more to open a previously working file, then when the file is finally visible and you compile it hangs on the compile window for an indefinite amount of time until you get this:

'Server responded with a failure code 502 - Bad Gateway'

Some acknowledgement and help would be well appreciated, one minute I'm super impressed at the way you can get fast results at prototyping stage with little investment then I'm super annoyed at being made to look daft when demoing it in front of the boss/client, please ARM lads at least give us a heads up when things are going wrong

Fingers crossed, it seems to be back up now.

posted by Angus Hutton-McKenzie 26 Sep 2016
3 years, 10 months ago.

No any response, oh, too bad, why not use more server?

Hello Mu, do you mean that I may be able to use another server? or was this directed at ARM?

posted by simon king 26 Sep 2016
3 years, 10 months ago.

Same problem here, exporting doesn't work either.

Edit: works again, thanks!

3 years, 10 months ago.

I have also problems to use the online compiler since 3 days. Sometimes I can compile then I get an error then nothing works or compiler does not start. Very annoying. The https://developer.mbed.org site is also sometimes very slow.

3 years, 11 months ago.

me too

What browser are you using on which OS? Are you using an ad blocker?

posted by Jan Jongboom 05 Sep 2016
3 years, 10 months ago.

Answer? I was excited about this but using an on-line compiles puts you entire project at the great risk. When the web site stops working there is nothing you can do about it.

I'm going to have to figure out how to abandon the on-line IDE.