6 years, 9 months ago.

Firmware upgrade Issue with Win 7

I am trying to upgrade my KL-25z's firmware from my windows 7 netbook but with no success. Unfortunately it looks like I got one of the older digikey boards that requires the firmware update to be usable from my mac.

Board info : MicroBoot Kernel Version is: 1.05 Bootloader Version is: 1.09 Application Version is: 0.00

no mbed.htm file comes up when in bootloader mode. Nothing appears connected to the computer when plugged in ordinarily

Here is what I'm trying, and the results :

1 - Hold reset and plug device into Win 7 computer - D4 LED does flash 2 - Open up BOOTLOADER drive that appears 3 - move in BOOTUPDATEAPP_Pemicro_v111.SDA to the bootloader drive's root, and wait for file to have moved 4 - Unplug board from comp, plug it back in 5 - After this I wait for up to a few minutes, but the green D4 LED does not blink at me and the bootload drive never shows up.

Other info : 1 - The board does not show up on my computer at all as a drive unless it is bootloader mode. I can't find it in devices 2 - LASTSTAT file says "Ready." when opened 3- BOOTUPDATEAPP_Pemicro_v111.SDA is not visible when re-opening in Bootloader mode 4 - PEdrivers should be installed (I went through the process and the folder shows up) 5 - The RGB LED on the board runs through a default program of a few colors and then slowly changes colors

What I may have broken : It is posible that I messed something up when first starting out since I did not initially see the note about Mac incompatibility with older firmware. So when I first got it, I plugged the board into my mac, and tried loading a generic test program over to the board. Perhaps that messed something up?

I recognize that perhaps I have just bricked the board, and it is no longer usable- in that case, is there a source to get a board with the most up to date firmware already on it?

Question relating to:

Commenting here, so you see there is a new comment: The updated firmware is required to load new mbed firmware in the future on a mac. But tbh I wouldn't expect many important new updates for that. The mbed firmware itself works perfectly fine on mac/linux, so to load programs there is no need to latest opensda firmware, since the mbed firmware handles that part.

posted by Erik - 02 Dec 2014

1 Answer

6 years, 9 months ago.

The file you mention is the bootloader update, but it is not the mbed firmware. (Still it should show up as mass storage device, which is a bit weird).

The mbed firmware is linked on the handbook page you made this question: http://developer.mbed.org/media/uploads/sam_grove/20140530_k20dx128_kl25z_if_opensda.s19.zip. Do the same thing, copy that file to the bootloader drive, and it should install mbed firmware which does run on your mac.

Accepted Answer

Thank you for the fast and on-point answer! I had done this when on the mac side, but had apparently messed that process up when doing it from windows. I did what you said and moved over the s19 file while in bootloader mode (held reset), and now I can find the board as a regular drive and it has the mbed.htm file when plugging it in not as a bootloader.

However, the bootloader version does not seem to have changed when opening the sda_info file. Right after moving the new s19 file over, the green D4 LED blinks rapidly for a second, then holds green, and my computer recognizes that something different is going on (it recognizes the new drive and loads drivers). But instead of coming up as a bootloader drive, the device comes up as a regular MBED drive (and waiting for a minute does not change that). Then when I boot it back up in bootloader mode, the sda_info gives the same results as before. Plugging in in bootloader mode right after loading the s19 file also does not solve the issue, nor does using a different USB port.

I have tried this process with rev 0203 and 0201 : 20140530_k20dx128_kl25z_if_opensda.s19 and mbed_if_v2_1_frdm_kl25z.s19 respectively

Edit : Strangely, I can now load code (or at least blinky) to my board from my mac despite the sda_info file claiming the 1.09 firmware is in place. I guess I'll just mark this resolved then, thanks!

posted by Stephen Hibbs 02 Dec 2014