4 years, 10 months ago.

Problem in flashing mbed LPC1768

Hello,

I am trying to flash mbed LPC1768. Each time I flash, it gets disconnected (obviously) but when I reconnect I can't see .bin file. I have tried to format drive once but there too one error occurred. After that I could see that .bin file has been removed and .htm file present on the drive.

I tried to flash it again but status LED did not blink. While saving .bin file from Firefox, firefox got hanged and after some time drive got disconnected. Again, .bin file was not flashed.

I tried to open .htm file present on the drive but it could not open.

Could you please suggest solution?

Thanks in advance.

Regards,

Abhijeet

Question relating to:

Hello,

I tried to flash simple LED blinking program using Keil and flashing was successful. So I am happy that I have not killed my mbed device.

But since the actual binary file that I want to flash is of 66Kb, I can't use Keil for that.

Regards,

Abhijeet

posted by Abhijeet Badurkar 27 Nov 2014
Comment on this question

1 Answer

4 years, 10 months ago.

Abhijeet,

You might want to start by checking out this Cookbook page. If you are using a machine with USB 3.0 ports, you might want to try using a different USB cable and/or placing a USB hub between the machine's USB port and your mbed device to see if that helps.

-Adam

Adam,

Thanks for the info. I had a look on the Cookbook page. All ports on my laptop are USB 2.0. I am gonna try on other ports.

I have one more question. If mbed drive has already .bin file, do I have to erase/delete it manually before flashing new file? If new binary file to be flashed has different name and if I save it on the drive, then will there be two binary files on the drive? Will there be any problem?

Thanks

-Abhijeet

posted by Abhijeet Badurkar 28 Nov 2014

Abhijeet,

It is ok if there are multiple files on the drive. It uses the newest one. At some point you might fill the drive and that will cause problems. Most GUI file viewers (Windows Explorer, Mac Finder) will just move the files to a trash folder on the drive when you delete them so they don't really free up space.

posted by Adam Green 28 Nov 2014

You need to log in to post a question