8 years ago.  This question has been closed. Reason: Too broad - no single answer

Windows COM port debug

Run FileTest sample under Debugger

Click on the Connection sub-tab. Set Type: to Serial Set Device: to a value appropriate for your environment. You can learn more about determining your serial port here.

I wonder what value i must set under Windows. My device connects on COM20 But if set value to "COM20" i've got an error

"Error in final launch sequence Failed to execute MI command: -target-select remote COM20 Error message from debugger back end: COM20: No such file or directory. COM20: No such file or directory."

Question relating to:

4 Answers

6 years, 2 months ago.

Same here... In eclipse I am getting:

Error in final launch sequence Failed to execute MI command: -target-select remote COM15 Error message from debugger back end: COM15: No such file or directory. COM15: No such file or directory.

Has this been resolved?

7 years, 7 months ago.

You can try \\.\com20

Sometimes Windows requires that format for higher COM port numbers.

Is there any way to debug the debugger connection?

posted by Daniel Flam 23 Apr 2014

Daniel, you can drop out of Eclipse and try using GDB directly to diagnose issues. If you are using the MRI debug monitor, then these two links may help further troubleshoot the issue https://github.com/adamgreen/mri/blob/master/notes/mri-getting-started.creole#installation and https://github.com/adamgreen/mri/blob/master/notes/mri-faq.creole#frequently-asked-questions

posted by Adam Green 23 Apr 2014
4 years, 9 months ago.

For me it worked with only 1 slash. \.\com25

6 years, 10 months ago.

I have the same issue, has it been solved somehow?