7 years ago.

Why temperature reported on iPad using BLE Health Thermometer app three times too high?

I used Donal Morrissey's Health Thermometer example with the nRF51822 mKit and a BMP180 pressure sensor/thermometer. I tested the thermometer on an STM32F401RE Nucleo board using the mbed compiler first to make sure the BMP180 library functioned properly. In this case it is reading 97.6 mPa and 78.2 degrees Fahrenheit at my desk. When I hooked up the BMP180 to the nRF51822 and used a modified version of Donal's BLE Health Thermometer example (http://mbed.org/blog/entry/Bluetooth-LE-example-on-mbed/), everything worked (except the Serial output and the output to the led display!), I got a connection to the iPad and, when I chose the nRF51xx device, I got a temperature and battery status. Great! However, the temperature was 64 C or 145 F depending on which output format I chose on the iPad. I am literally copying Donal's program and substituting the floating point temperature out from the BMP180 for the one output for the TM102. If I could get Serial out I could at least verify the temperature coming out of the BMP180, but when I look for a COM port using HyperTerminal I don't see one! How does one get Serial output from the nRF51822? I'd like to post the code but I don't see how to post code from the mbed compiler here. Anyone have a suggestion for me to try next? Thanks.

Question relating to:

The nRF51822-mKIT is a low cost ARM mbed enabled development board for Bluetooth® Smart designs with the nRF51822 SoC. The kit gives access to all GPIO pins via pin headers …

2 Answers

3 years, 3 months ago.

I'm looking for an iPad application that would show the time of detection of various substances in the body. For example: how long does alcohol stay in your system. How long alcohol can be detected in hair, saliva, urine and blood. Do you know of such applications?

7 years ago.

include this snippet for console output

Serial  console(USBTX, USBRX);
console.printf("hello world\r\n");

I already had this Serial call in the program:

Serial pc(USBTX, USBRX); tx, rx

When I run on the STM32F401RE Nucleo and call up HyperTerm, I usuallycan identify a COM port to open to receive Serial output. In the case of the nRF51822, I can identify no new COM port. Is the problem that this program runs directly on the nRF51822 and doesn't go through the on-board ARM processor. I am a little confused as to exactly how the nRF51822 is interfacing with the Serial here.

posted by Kris Winer 04 Jul 2014